Transmission won't start. Permission problem?

  • It's not entirely impossible that there could be corruption on your system drive, but I don't think that's the likeliest option. If you want to completely remove Transmission and the plugin and you've installed the plugin from OMV then issuing apt-get autoremove --purge openmediavault-transmissionbt should normally be enough. That will purge the plugin and all it dependencies.

    What I think you're seeing and the reason to why it worked before, but not now is a change with later versions of the plugin (or rather, a reverted change to how the original plugin actually worked). The plugin used to add the user debian-transmission to the users group (which means that it would've worked for you now since users has enough permissions). If you look at the NAS it's working on I would guess that issuing groups debian-transmission will show the users group. The issue with that is that system users shouldn't be added to the users group without the consent of the administrator since it can be a security issue (think of malfunctioning services having the access to all files and directories which the users group has access to).

    So, what you can do is multiple things. You can either add debian-transmission to the users group (which I personally wouldn't do), or you can use ACLs to manage permissions. The con with the second option is that ACLs sometimes can be hard to work with. The third option (which I use) is to create a new group, for example download-adm and add the user debian-transmission to it. Then you change the group of the download directory to your new group instead and it should work. Now you can add all users that should be able to manage downloads to the new group and everything should work as you've intended. For read only access you can then set permissions to read only for others.

    The permissions are still wrong from what I can see from your picture, so you need to figure out why they didn't change when you tried to change them. :)

    I would've issued these commands:

    chmod 755 /media
    chmod 755 /media/497065c1-1ce1-4f12-8ad3-0b110d69572a

    A last suggestion would be to select the text in Putty that you want to show us and then right click it to copy it. Then use the code tag on the forum and paste the output in it. That way you don't have to upload pictures each time.

  • I tried again changing permissions and creating the new group as you suggested, but nothing still same problem.
    You are right the picture I added was taken before executing the chmod -R 777 /media/uuid

    root@NAS106:/media/497065c1-1ce1-4f12-8ad3-0b110d69572a# ls -al
    total 28
    drwxrwxrwx 8 mastro users 73 Jan 11 23:16 .
    drwxrwxrw- 7 mastro users 4096 Oct 18 16:47 ..
    drwxrwsrw-+ 4 mastro users 35 Jan 10 00:35 001
    drwxrwsrw- 8 mastro users 4096 Oct 18 18:56 Bkup
    drwxrwsrwx+ 2 mastro users 6 Jan 11 23:16 dnl
    drwxrwsrw-+ 7 mastro users 99 Aug 30 21:19 Lavoro
    drwxrwsrwx+ 7 mastro users 71 Jan 13 18:54 Media
    drwxrwsrwx+ 4 mastro users 30 Jan 13 14:43 temp

    Good to know I can copy putty session to clipboard

    cleaned up everything using the command you suggested.
    to reinstall the plugin should i do it manually (apt-get install openmediavault-transmissionbt) or is better to use plugin installation from OMV web gui?

  • You're nearly there if I'm seeing it correctly. You just need to fix this drwxrwxrw- 7 mastro users 4096 Oct 18 16:47 ... That means that /media still is missing executable rights for others. Run the two commands I gave you and see if it works after it. You don't normally want /media world writable, but that's of course up to you. :)

    Good to know I can copy putty session to clipboard

    Don't forget to add the pasted text in code blocks; [code]your text[/code] so that it's easier to read.

  • I have just reinstalled transmission from plugin web gui
    why do I have to give /media and /media/uuid executable permission for other? In any case I gave to that folders permission 777 and didn't work (chmod -R 777 /media/uuid/temp)
    on the other NAS I dnd't have to do this.. going to reconfigure transmisison and shared folders from scratch...
    and :D:D
    it is working now.. I didn't have to do anything special, simply reconfigured transmission and shared folders as done before... I am quite sure something was wrong with the first installation of the plugin.
    the clean up solved everything...thanks a lot for the help :thumbsup:

  • here are the permissions of the folders... after the new installation
    root@NAS106:/media# ls -al
    total 28
    drwxr-xr-x 7 mastro users 4096 Oct 18 16:47 .
    drwxr-xr-x 24 root root 4096 May 3 2015 ..
    drwxr-xr-x 8 mastro users 73 Jan 14 01:57 497065c1-1ce1-4f12-8ad3-0b110d69572a

    root@NAS106:/media# cd 497065c1-1ce1-4f12-8ad3-0b110d69572a/
    root@NAS106:/media/497065c1-1ce1-4f12-8ad3-0b110d69572a# ls -al
    total 24
    drwxr-xr-x 8 mastro users 73 Jan 14 01:57 .
    drwxr-xr-x 7 mastro users 4096 Oct 18 16:47 ..
    drwxrwSrw-+ 7 mastro users 71 Jan 13 18:54 Media
    drwxrwsrwx 4 root users 35 Jan 14 02:00 temp

    root@NAS106:/media/497065c1-1ce1-4f12-8ad3-0b110d69572a/temp# ls -al
    total 4
    drwxrwsrwx 4 root users 35 Jan 14 02:00 .
    drwxr-xr-x 8 mastro users 73 Jan 14 01:57 ..
    drwxrwsrwx 4 root users 90 Jan 14 02:31 incomplete
    drwxrwsrwx 2 root users 4096 Jan 14 02:30 watch

    I can see the executable permission for others...
    thanks for the support

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!