ASUS H170I-PLUS D3

  • Hi,


    I have built a new Home-Server and tried to install OMV 2.1 on it, but now I have 2 Problems that keep me from installing OMV.


    First the Motherboards Network-Adapter (Intel I219-V Gigabit Lan) doesn't seem to be supported by Debian Wheezy (too new?). I downloaded the Drivers for the I218-V Version and put it in /firmware folder of the bootable USB-Drive, but even then the Debian-Installer doesn't detect it. So I continued the setup without Network/Internet Support.
    The second problem is the SSD Samsung M.2 SM951-NVMe. eventhough the Mainboard detects it, and i partitioned it with GParted, the Debian installer does not.


    Any help for either of these Problems is much appreciated.

  • I used "openmediavault_2.1_amd64.iso" on a bootable USB stick made with UNetbootin, then I tried "debian-7.9.0-amd64-netinst.iso". Same results with both.

  • I have a bad feeling about this (more likely to use Jessie). I think you will need to use another method for installing. Like debootstrap.
    First thing I would try is to boot systemrescuecd, see if the hw gets recognized there. Starting with the network and the disk.

  • Format your HDD in FAT32 then install OMV using a bootable USB or CD (Try using Rufus).
    After installing you can use GParted to create a partition as per your requirement.


    Had a similar issue with G41 boards few days ago, did the same and it worked for me.


    Let me know if it worked.

  • Varunpilanker thanks, I tried what you said, but it didn't help.


    Anyway, I got the System running now.


    First I had to put in an old 60GB SSD and install OMV 2.1 without network support on it.
    Then I installed OMV 2.1 on a Virtual Machine on another computer, so I could install "build essential" and compile the Intel network drivers on the VM, then copy the binary file to /lib/modules/<KERNEL VERSION>/kernel/drivers/net/e1000e/e1000e.ko on the Server, after that I executed modprobe e1000e , that installed the driver. (This helped me alot: http://forums.linuxmint.com/vi…p?f=150&t=209410#p1093886)
    To get the network configured i had to run omv-firstaid, then do "configure network interface". After that the Server got an IP from the router, but still no internet. For that I had to add nameserver 8.8.8.8 the google DNS to /etc/resolv.conf.


    With the OMV and the Internet now running on the Server, I installed OMV-Extras and the Backport Kernel 3.16 . Now OMV recognizes the NVMe SSD. I had hoped to install OMV on the NVMe SSD directly, but as it is now it's ok. I use the NVMe drive to store the Plex Database and probably i'll find some other use for it.

  • Subzero,
    I just aquired these few skills the past days trying to get my system to work :) .
    I looked up debootstrap, but not in detail. Also I think it will not help me in this case. Because there seems to be another Problem with NVMe Drives that I didnt mention in my last post. Before i put in the old 60GB SSD and installed OMV, I downloaded Debian Jessie and tried to install it on the NVMe. The NVMe showed up in the installation process, I could partition it and install Debian on it, but on the step where The Bootloader should be installed I get an error. I did some reasearch and found out that it has something to with the NVMe not being loaded as /sda but as /nvme...something, I'm not exactly sure. Anyway thats when I got fed up and just decided to put the old SSD in.

  • Take another read then again at debootstrap, your installing debian from a running system that already sees your drive. Debootstrap does not include kernel installation, but once you've chroot into it you can call the apt-get install for backport kernel.
    I am thinking about writing a guide, is not trivial for some users, but very practical in some cases, like yours..

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!