[GUIDE-Questions] DEBOOTSTRAP: Installing Debian into a folder in a running system

  • Great guide!

    One remark:

    blkid | grep -i sb

    should be

    blkid | grep -i sdb

    shouldn't it?

    OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system

  • Hi guys,

    I've just registered to say thanks for this guide! Spent half a day yesterday struggling to setup OMV on my new shiny Intel NUC based on Intel i219-V ethernet adapter.
    Tried many things, standard installer couldn't find any network device. Ubuntu Live USB did work, but Debian Live USB did not so I got little confused.
    Then I found this which led me to debootstrapping Debian installation from a working Ubuntu Live USB.

    In general it worked fine, however I do have few comments someone else might find helpful.

    Step 1: Debootstrapping

    Let's install Debian into /target directory

    debootstrap --arch=amd64 wheezy /target http://httpredir.debian.org/debian/

    I decided to go with most recent stable release which is stretch at the time of writing so I just replaced wheezy with stretch to make it work here.
    Later when editing sources.list and backports.list I had to alter that as well (got it from official Debian page):

    Code: sources.list
    deb http://deb.debian.org/debian/ stretch main contrib non-free
    deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
    deb http://deb.debian.org/debian-security stretch/updates main contrib non-free
    Code: backports.list
    deb http://ftp.debian.org/debian stretch-backports main contrib non-free

    Going further:

    Step 3: Install the grub loader and the kernel

    First we install openssh-server and initramfs-tools. The first is necessary to access remotely from the network when we boot the new system, the second is for installing kernel

    apt-get install openssh-server initramfs-tools/wheezy-backports

    Even after changing wheezy to stretch it couldn't find the package so I just skipped that step (installed only the ssh server) and went with kernel installation - no issues there.
    Regarding the kernel I wanted to pick a newer one, so I ran apt-cache search linux-image-4 to list them. Ended up with linux-image-4.19.0-0.bpo.1-amd64
    It went well, without any errors.

    Here comes the tricky part regarding network interface. I went with the guide regarding the update to /etc/network/interfaces, rebooted and found out there is no network on my machine.

    I had to install few tools to help myself out. So apt-get install pciutils lshw but for that you need internet access so I had to go back to working Ubuntu Live USB and chroot again following the instruction (mounting /dev, /sys and stuff before). Reboot again to Debian after that.
    First let's make sure the system has the driver loaded (which it should) by executing lspci -v | grep Eth -A 10. The result should be similar to:

    It's using e1000e which is correct according to Intel specs.
    Next let's see what's the name of the interface:

    It turns out it's eno1 when I was expecting eth0 and when I was still chrooted from Ubuntu I'm pretty sure it was eth0. eno1 refers to onboard NIC which is actually true here and probably that's how it is on Intel NUCs.
    That was the last thing to be changed. After changing eth0 to eno1 in /etc/network/interfaces and rebooting I was finally online!

    Hope this saves someone some time.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!