Installation on a fresh Debian Jessie - dependance problems

  • I have installed a "fresh" Jessy: Linux omv 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u2 (2016-01-02) x86_64 GNU/Linux; then I try to install OMV with the proposed script as proposed:

    Code
    echo "deb http://packages.openmediavault.org/public erasmus main" > /etc/apt/sources.list.d/openmediavault.list
    apt-get update && apt-get upgrade
    # Note: You will get a warning that the PGP Key can't be found. Thats fine.
    apt-get install openmediavault-keyring postfix apt-transport-https
    # Note: You will get a warning that the package 'openmediavault-keyring' can't be authenticated. You're fine to ignore that warning and install it anyways.
    apt-get update
    apt-get install openmediavault


    But I get a lot of dependencies problems. Any idea ?

  • While I don't think you should be testing OMV 3 yet, what are the dependency problems? Where did you get this "script"? You don't need to do apt-get upgrade in line 2. The system should be updated before installing omv You don't need apt-transport-https (omv-extras will install it though).

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Don't worry. I have reformatted and re-installed from 0 with the usual distribution openmediavault_2.1_i386.iso in between.


    The depencies problems was theses:
    openmediavault : Dépend: php5-fpm mais il n'est pas installable
    Dépend: php5-cgi mais il n'est pas installable
    Dépend: php5-cli (>= 5.6) mais il n'est pas installable
    Dépend: php5-pam mais ne sera pas installé
    Dépend: php-json-schema mais ne sera pas installé
    Dépend: sudo mais il n'est pas installable
    Dépend: ethtool mais il n'est pas installable
    Dépend: ifenslave mais il n'est pas installable
    Dépend: resolvconf mais il n'est pas installable
    Dépend: xfsprogs mais il n'est pas installable
    Dépend: jfsutils mais il n'est pas installable
    Dépend: ntfs-3g mais il n'est pas installable
    Dépend: hdparm mais il n'est pas installable
    Dépend: sdparm mais il n'est pas installable
    Dépend: bootlogd mais il n'est pas installable
    Dépend: postfix mais il n'est pas installable
    Dépend: cpufrequtils mais il n'est pas installable
    Dépend: smartmontools mais il n'est pas installable
    Dépend: openssh-blacklist-extra mais il n'est pas installable
    Dépend: uuid mais il n'est pas installable
    Dépend: nfs-kernel-server mais il n'est pas installable
    Dépend: proftpd-basic mais il n'est pas installable
    Dépend: tftpd-hpa mais il n'est pas installable
    Dépend: samba mais il n'est pas installable
    Dépend: samba-common-bin mais il n'est pas installable
    Dépend: rsync mais il n'est pas installable
    Dépend: snmpd mais il n'est pas installable
    Dépend: avahi-daemon mais il n'est pas installable
    Dépend: libnss-mdns mais il n'est pas installable
    Dépend: monit (>= 5.4) mais il n'est pas installable
    Dépend: beep mais il n'est pas installable
    Dépend: gdisk mais il n'est pas installable
    Dépend: rrdtool mais il n'est pas installable
    Dépend: collectd (>= 5.1.0) mais il n'est pas installable
    Dépend: anacron mais il n'est pas installable
    Dépend: cron-apt mais il n'est pas installable
    Dépend: quota mais il n'est pas installable
    Dépend: quotatool mais il n'est pas installable
    Dépend: lvm2 mais il n'est pas installable
    Dépend: watchdog mais il n'est pas installable
    Dépend: libjson-perl mais il n'est pas installable
    Dépend: liblocale-po-perl mais il n'est pas installable
    Dépend: proftpd-mod-vroot mais ne sera pas installé
    Dépend: libjavascript-minifier-xs-perl mais il n'est pas installable
    Dépend: xmlstarlet (>= 1.6.1) mais il n'est pas installable
    Dépend: parted mais il n'est pas installable
    Dépend: socat mais il n'est pas installable
    Dépend: rrdcached mais il n'est pas installable
    Dépend: nginx (>= 1.6.2) mais il n'est pas installable
    Dépend: python3 mais il n'est pas installable
    Dépend: python3-apt mais il n'est pas installable
    Dépend: pm-utils mais il n'est pas installable
    Dépend: wpasupplicant mais il n'est pas installable

  • I don't want to spend too much time on this since there is an OMV3 iso and it is still beta. Looks like you are still on Wheezy. What is the output of cat /etc/debian_version

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi, habe debian8 mit erasmus installiert (testen) soweit so gut. jedoch bekomme probleme beim aktualisieren der extras..... z.b. http://dh2k.omv.extras.org/deb…ain/binary-amd64/Packages fehlgeschlagrn: 404 not found <-- das nur eines von mehreren Einträgen....


    The virtualbox plugin will use virtualbox from the debian repos. So, that repo isn't needed. You must be using an old version of omv-extras. Download a new version.


    Openmediavault 3.x - Important Information!

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!