openmediavault-letsencrypt

  • I now have also this error when I want to renew with an additional domain:


    >>> *************** Error ***************
    The configuration object is in use
    <<< *************************************


    Any ideas?


    Regards lulu

  • I know the ',' is add more host name, but I plan to add another hostname from a different directory.
    Not the same one that I currently use, is SNI Proxy the only way?

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro


  • The reason for this is that you have the certificate in use in OMV (I know, this is the reason why you use the plugin in the first place ;-) ) I faced the same issue and the way I resolved it is to switch OMV to use a self-signed certificate then (re-)create the LE certificate. Unfortunately, even though I succeeded with the re-creation of the certificate and I do find a new one in /etc/letsencrypt/live, it did not make it into OMV's config file and I will have to edit the file manually so I have the new certificate available for OMV. I do have the strange feeling the plugin does not (always) work as expected.
    I might write a script to do that if I find the time as I'm using the certificate for two OMV systems and create the cert on one of them so the "problem" to add the cert into OMV's config is the same ;-)


    Regards,
    SlashOpt

    OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system

  • The reason for this is that you have the certificate in use in OMV (I know, this is the reason why you use the plugin in the first place ;-) ) I faced the same issue and the way I resolved it is to switch OMV to use a self-signed certificate then (re-)create the LE certificate. Unfortunately, even though I succeeded with the re-creation of the certificate and I do find a new one in /etc/letsencrypt/live, it did not make it into OMV's config file and I will have to edit the file manually so I have the new certificate available for OMV. I do have the strange feeling the plugin does not (always) work as expected.
    I might write a script to do that if I find the time as I'm using the certificate for two OMV systems and create the cert on one of them so the "problem" to add the cert into OMV's config is the same ;-)


    Regards,
    SlashOpt


    I'm using a self-cert for OMV, and LE for my webservers, but I'm still having this error.
    I've to deleted the files in CSR and keys folders, and un-install the plugin to generate new certs.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • Thanks!


    I was hoping to come across something like this! I'm currently using a free StartSSL certificate on my OMV server, and for whatever reason, my phone always shows the red "https" with a strike through it and complains about the certificate being self-signed.

  • Setup new omv instance and installed lots of plugins, but the letsencrypt one does not open, just stays on the page for the previous plugin, even though the let encrypt one is selected.


    I have reinstalled and rebooted several times but no improvement?


    The plugin works fine on my other machine.

  • Setup new omv instance and installed lots of plugins, but the letsencrypt one does not open, just stays on the page for the previous plugin, even though the let encrypt one is selected.


    I have reinstalled and rebooted several times but no improvement?


    The plugin works fine on my other machine.


    Hi,


    I once faced the same issue (I think I also posted about it earlier in this thread). The plugin worked perfectly on my virtual system I use to test things but on my main system it showed the same behaviour as you describe. I tried to debug this and found that at the time you click on the 'let's encrypt' entry in the menu a variable in Javascript is set to an empty string and so the call failed. When I entered the correct value (can't remember what it was atm (openmediavault-letsencrypt?)) it worked. I found out all this as Firefox showed an Javascript exception and I installed the Firebug addon for further investigations. Unfortunately I could not find any bug in the plugin's code which would have fixed the issue :-(
    The way I fixed this at the time I faced the problem: I wanted to re-install my system since some time anyway so I just did that and the problem was gone. I know that this will not really help you with the issue but at least you know that someone else faced the same issue and there's (up to now) not a real solution for it.


    SlashOpt


    Edit: just had a look. It was end of February (page 5 of this thread) when we discussed this issue

    OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system

  • Maybe your pop-up blocker interfered it?
    If Java is the issue, clear your browser history/cookies, and try on a different browser such as FireFox, Edge...

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • I have purged all non-ported plugins from all OMV 3.x omv-extras repos.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • For my day-job I've been installing security and certificates for years, and ever since Snowden stuff has changed. LetsEncrypt is great, but I can recommend using https://github.com/Neilpang/acme.sh instead of the certbot python monstrosity and dependency hell.


    By the way, pity we're still at nginx -v 1.6.* on OMV3. I would love to use http2 and be able to use this config:
    https://gist.githubusercontent…cb67d85e1454b10997566/TLS
    We only get a B- at qualys ssllabs test.

  • I adapt omv-letsencrypt to OMV 3.0.26
    I made a pull requests
    before accepted, anyone who interested can test my omv-letsencrpyt which is adapted to 3.0.26


    https://github.com/luxflow/openmediavault-letsencrypt


    How to use?
    Enable `OMV-extras testing repo`
    install openmediavault-letsencrypt 3.X
    enjoy



    #HOW CAN I USES MULTIPLE SUBDOMAINS?
    change example domain according your domain (*.example.org)
    1. add OMV_NGINX_SITE_WEBGUI_SERVERNAME,
    this will be your omv admin domain


    vim /etc/default/openmediavault
    OMV_NGINX_SITE_WEBGUI_SERVERNAME="omv.example.org"


    2. add file to /etc/nginx and /etc/nginx/site-enabled
    below is example file for subdomain irc



    /etc/nginx/http

    Code
    listen [::]:80;
    location /.well-known/ {
    root /var/www/openmediavault;
    }
    location / {
    return 301 https://$server_name$request_uri;
    }


    /etc/nginx/https


    /etc/nginx/site-enabled/irc

    OMV3 on Proxmox
    Intel E3-1245 v5 | 32GB ECC RAM | 4x3TB RAID10 HDD
    omv-zfs | omv-nginx | omv-letsencrypt | omv-openvpn
    Click link for more details

    Edited 8 times, last by luxflow ().


  • Correct me if I'm Wong but it is compatible with the latest version of omv as well.



    Sent from my iPhone using Tapatalk

  • yes I'm on 3.0.29 and tested it works also
    for master branch?, I didn't test it
    IMHO, it will also works in master branch since there are no big difference in commit log

    OMV3 on Proxmox
    Intel E3-1245 v5 | 32GB ECC RAM | 4x3TB RAID10 HDD
    omv-zfs | omv-nginx | omv-letsencrypt | omv-openvpn
    Click link for more details

    Edited once, last by luxflow ().

  • yes I'm on 3.0.29 and tested it works also
    for master branch?, I didn't test it
    IMHO, it will also works in master branch since there are no big difference in commit log


    Why don't you propose a patch with your mods on the original maste branch? In this way it will directly be integrated in omv extras



    Sent from my iPhone using Tapatalk

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!