NUT settings for UPS Trust OXXTRON 1300VA

  • Hallo.

    I'm running OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
    Today i got my UPS UPS Trust OXXTRON 1300VA.
    I installed the NUT plugin.
    I tried several driver configurations like the Trust driver form the NUT Hardware compatibility list.

    I tried

    driver = blazer_ser
    port = auto


    driver = blazer_usb
    port = auto

    i also tried the port usb and several other drivers but nothing. when i go to the system->ups tab i receive the error

    Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected
    Errore #4000:
    exception 'OMVException' with message 'Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected' in /usr/share/openmediavault/engined/rpc/
    Stack trace:
    #0 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
    #1 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('getStats', NULL, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('Nut', 'getStats', NULL, Array, 1)
    #4 {main}

    my lsusb

    Bus 002 Device 005: ID 0925:1234 Lakeview Research 
    Bus 004 Device 002: ID 0781:5567 SanDisk Corp. Cruzer Blade
    Bus 004 Device 004: ID 0424:2228 Standard Microsystems Corp. 9-in-2 Card Reader
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    My bc is up to date

    i tried also some command found in other threads similar like

    sudo /lib/nut/blazer_usb -a usb -x vendorid=0925
    Network UPS Tools - Megatec/Q1 protocol USB driver 0.08 (2.6.4)
    Error: Section usb not found in ups.conf

    Can somebody give me some hints to solve this please


    OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586

  • Maybe this can help more



    OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586

  • i got uone step further.

    i changed my configuration to

    driver = usbhid-ups
    port = auto
    vendorid = 0925
    productid = 1234

    now when i hit

    i get the above output but it says they don't match, althought the vendor and product id appear in the checked devices.

    i tried other drivers like


    but i get this

    Network UPS Tools - Generic HID driver 0.37 (2.6.4)
    USB communication driver 0.32
    Error: UPS [trust] is for driver richcomm_usb, but I'm usbhid-ups!

    So any idea? i looked also in the manpages of usbhid-ups but its not my knowledge.

    Thanks for replies

    OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586

  • Ok i solved by my own with the kind help of the NUT mailing list members.

    My configuration for UPS Trust OXXTRON 1300VA is:

    driver = richcomm_usb
    port = auto

    It seems that the only information given from the UPS the following

    The status:

    OL / OB / BL

    are shown correct i think when the supply status changes.
    When the ups is attached on the AC it shows

    OL (online i think)

    When i take away the power from the ups it shows

    OB (on battery i think)

    When the battery is low it show

    BL (battery low i think)

    it respects also the given shutdown or suspend settings of the plugin.

    If somebody figures out how to squeeze more information out of it i would be interested 8o

    OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586

  • Hallo All.

    I update my system to version 4 and now i'm trying to configure it again but i have a problem giving the ups a name.

    i always get the error on saving the configuration

    Any ideas to help?

    Thanks in adavnce

    OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586

  • The regex requires only lower case which may be one of the reasons that its refusing "UPSTESTNAME".

    I'm also having the same problems right now too and have tried a number of usernames and they all throw the same error.

    If anyone can shed some light I'd be greatly appreciative.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!