Extremely slow NFS writes

  • I have an NFS share mounted on my debian server. I was getting writing speeds in the KB/s range, so did some research and added async to the mount options, and now getting 16 MB/s write speeds, still way below acceptable. I then mounted my SMB share from openmediavault on my debian server and got 56MB/s speeds. Why are my NFS speeds so much lower than my SMB speeds? Also, don't understand how it says my NFS read speed is 8.2GB/s...


    mount

    Code
    192.168.1.125:/RemoteStorage on /mnt/RemoteStorage type nfs4 (rw,relatime,sync,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.150,local_lock=none,addr=192.168.1.125)


    fstab

    Code
    192.168.1.125:RemoteStorage /mnt/RemoteStorage nfs4 rw,sync,hard,intr 0 0


    /etc/exports on server

    Code
    /export/RemoteStorage 192.168.1.0/24(rw,subtree_check,secure,async)



  • It would help if I didn't mount the nfs shares with "sync" when I specified "async" on the server. Removed the "sync" option and the nfs speed rose by a large amount.

  • Greetings,


    Despite the fact that the solution is from more than 6 years ago, it served me too much. I had been with the failure for more than 15 days and could not find the solution.


    My case is a server with OpenMediaVault with version 5.6.1-1 and I have a shared resource by NFS which transmitted before 100 MB / s to 250 MB / s and after the failure it went to 11 MB / s or less, but this was one moment after another that I stopped doing it, the only thing I remember doing before this error was running some updates (more than 30) that were available and then the failure began.


    Configure the NFS, in the options of Services> NFS> Shared, the resource with:


    rw, subtree_check, insecure, no_root_squash, async


    Problem solved, Thanks and regards.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!