Cannot remove openmediavault-roundcube, openmediavault-mysql, no webgui, ssh accessible and Nginx cannot start.

  • Hello,


    I apologize in advance if this is not the correct section for posting. This is my first time partaking in a forum. I am facing various problems.I installed roundcube and all sorts of weirdness began. Before I (foolishly) rebooted the server, I received error 4000. One problem is that Nginx won't start and Nginx.conf test failed. Any time I try to make modifications to packages such as



    There is an error code.


    I have also tried dpkg -l | grep openmediavault which gives me this



    If I try dpkg -l | grep mysql


    Code
    dpkg -l | grep mysql
    ii libdbd-mysql-perl 4.021-1+b1 amd64 Perl5 database interface to the MySQL database
    ii libmysqlclient18:amd64 5.5.47-0+deb7u1 amd64 MySQL database client library
    ii mysql-client-5.5 5.5.47-0+deb7u1 amd64 MySQL database client binaries
    ii mysql-common 5.5.47-0+deb7u1 all MySQL database common files, e.g. /etc/mysql/my.cnf
    ii mysql-server 5.5.47-0+deb7u1 all MySQL database server (metapackage depending on the latest version)
    ii mysql-server-5.5 5.5.47-0+deb7u1 amd64 MySQL database server binaries and system database setup
    ii mysql-server-core-5.5 5.5.47-0+deb7u1 amd64 MySQL database server binaries
    rH openmediavault-mysql 2.1 all MySQL plugin for OpenMediaVault.


    The OMV Webserver does not work although other services do. All I get is a page saying "It works!"


    If I try to start nginx with service nginx start, this is the output


    Code
    service nginx start
    Starting nginx: nginx: [emerg] "client_max_body_size" directive invalid value in /etc/nginx/openmediavault-webgui.d/openmediavault-webdav.conf:3
    nginx: configuration file /etc/nginx/nginx.conf test failed


    Please help, I have reached a dead end and no other forum post that I have read has helped.

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • This is the output of apt-cache policy nginx


    Code
    apt-cache policy nginx
    nginx:
    Installed: 1.2.1-2.2+wheezy3
    Candidate: 1.2.1-2.2+wheezy3
    Version table:
    *** 1.2.1-2.2+wheezy3 0
    500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
    500 http://security.debian.org/ wheezy/updates/main amd64 Packages
    100 /var/lib/dpkg/status


    Thanks for the assistance @subzero79

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • Ok so I tried accessing the webgui in a different web browser and there is no connection. Shares and services are still working. This is the output of service apache2 status


    Code
    service apache2 status
    Apache2 is NOT running.


    This confirms that the problem is not related to apache2 but I still do not know how to repair the server. Here is the output of service nginx status


    Code
    service nginx status
    nginx is not running ... failed!

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • This is the output of omv-showkey webdav


    Code
    omv-showkey webdav
    <webdav>
    <enable>1</enable>
    <sharedfolderref>07312a05-b635-4ece-97b8-4d5430932819</sharedfolderref>
    </webdav>

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • @subzero79, my server's webgui does not work, I cannot access it. This all started after I installed roundcube /mySQL and figured that the service would not fit my needs so I uninstalled it. The WebGUI for Plex is still working if that is of any use to indicate the problem.

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • sorry i forgot about that. Somehow the plugin is missing an entry in the config.xml when it was installed


    Try apt-get purge openmediavault-webdav, After that look at this folder /etc/nginx/openmediavault-webgui.d/ make sure the webdav file is gone otherwise remove it manually.


    The start nginx /etc/init.d/nginx start

  • This is the output of apt-get purge openmediavault-webdav



    If i try to remove a package, there is an error. Sorry to ask this but I am a linux Noob and do not know how to browse a folder. What command would I use to browse for /etc/nginx/openmediavault-webgui.d/? cd maybe?

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • @subzero79 I removed the webdav.conf and started nginx. Thankfully you have restored my ability to login and edit items. I am in deep gratitude to you. Shall I do a test reboot to ensure the system is fully working?

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • I rebooted and everything worked correctly. Thank you very much to @subzero79 for assisting me in repairing openmediavault.

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • @subzero79 This is the result of apt-get purge openmediavault-webdav


    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

  • This is the output of apt-get -f install


    Code
    apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.


    From this code it seems that there is nothing left to repair. Only 1 package to upgrade. Thank you @subzero79.

    "It is better to offer no excuse than a bad one." -George Washington


    Current OMV Server Configuration: 8GB Avexir DDR4 Ram, Pentium G4400 Dual Core CPU, Corsair CS550M Power Supply, Fractal Design Core 1100, 2X2 TB WD RE4 HDD, MSI B150M-PRO VD, 2X ISTARUSA 5.25 to Hot Swap Drive Trays.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!