Web Interface stops working after a few seconds

  • Hello,
    everything worked fine until i wanted to change the network adapter.
    My OnBoard LAN is the new Intel I219 NIC. For the installation I used another Intel NIC (a pretty old one) and installed the latest backport kernel.
    Now I am not able access the webinterface anymore.
    I also tried to switch back to the other NIC but it doesn`t work either.


    Everything else ist working (SSH, Plex, Teamspeak ...) perfectly without any issues.


    I got the following problem:
    After er restart the Server i can access the web interface and I am also able to log in. But after a few seconds it is loading and loading and loading. After a minute I get pop up messages like "connection fauliure" and I cant access the interface anymore. If I reload the page I usually get a simple error message "network timeout". But sometimes I also get the message "Error 504 - Gateway timed-out ... nginx"
    I cant make any changes in the web gui. After I want to apply a change the web gui is loading endless again.


    Firewall is disabled btw.

  • try too to use from CLI omv-firstaid and assing NIC and configure it, this recreate config and perhaps clean some garbage from your nic intechanges.

  • Login via SSH and execute the following CLI commands:


    Quellcode (2 Zeilen)


    After that login via WebGUI and check the omv-engined command coutput.


    If I try to apply a change:

    Code
    Executing RPC (service=WebGui, method=setSettings, params={"port":80,"timeout":0,"enablessl":false,"sslcertificateref":"","sslport":443,"forcesslonly":false}, context={"username":"admin","role":1}) ...
    Child process forked (pid=11396)
    Executing RPC (service=Config, method=isDirty, params=null, context={"username":"admin","role":1}) ...
    Child process forked (pid=11399)



    If I try to repair my NIC:

    Code
    Configuring network interface. Please wait ...
    {"response":null,"error":{"code":7001,"message":"Failed to connect to socket: No such file or directory","trace":"exception 'OMVException' with message 'Failed to connect to socket: No such file or directory' in \/usr\/share\/php\/openmediavault\/rpc.inc:135\nStack trace:\n#0 \/usr\/sbin\/omv-rpc(107): OMVRpc::exec('Network', 'setEthernetIfac...', Array, Array, 2)\n#1 {main}"}}
    Failed to execute RPC (service=Network, method=setEthernetIface)
  • I just reinstalled the whole OS and everything seems to work again.
    I will stick to the PCIe Etherenet Card until OMV 3 gets releaesed. Maybe i can just use my OnBoard LAN out of the box ;)

  • Are you using the backports 3.16 kernel? You can install it with omv-extras. This kernel is the same default kernel that OMV 3.x will use.

    omv 5.6.8 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Are you using the backports 3.16 kernel? You can install it with omv-extras. This kernel is the same default kernel that OMV 3.x will use.


    Yes Iam using the current 3.16 backports kernel.
    Is there something else which I have to configure? Or can I just unplug the cable from my PCIe NIC and put it into my OnBoard NIC?
    Because this crashed my whole system :S

  • What crashed your whole system? If you change NICs, make sure to set the network information before doing it.

    omv 5.6.8 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I dont know which changed setting caused the issues but now everything seems to work.
    I added a new Ethernet Port (eth1 = Onboard) and removed the "old" one (eth0 = PCIe NIC). I restarted the system once and now everything is working perfectly ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!