Upgrading from LILO to Grub2

  • Hello, I previously posted a different topic regarding my recent reinstall of OMV. I was able to resolve my WebGUI issue but there was something I wanted to fix, though its not broken exactly. When I installed this new OMV installation, I got an error when trying to install Grub so I went for LILO, but I've noticed that LILO takes a lot longer to boot up than Grub. I'd like to install Grub instead. I looked up some guides and I downloaded Grub onto my system, but when I try to run

    Code
    grub-install /dev/sdb


    I get the following output:


    I don't know how to resolve this. Please help.


    Thanks.

  • Sure, here it is:


    Code
    Disk /dev/sda: 4000.8 GB, 4000787030016 bytes
    255 heads, 63 sectors/track, 486401 cylinders, total 7814037168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk identifier: 0x00000000
    Disk /dev/sda doesn't contain a valid partition table


    That's one of the HDDs in my RAID. I have 4 4TB disks and one 40GB disk that's holding the OMV installation.


    Here is the sdb, just in case:

  • Here you go:


  • Here is what I get:

    Code
    root@Luna:~# dpkg -l | grep grub
    ii grub-common 1.99-27+deb7u3 amd64 GRand Unified Bootloader (common files)
    ii grub-legacy 0.97-67 amd64 GRand Unified Bootloader (Legacy version)
    rc grub-pc 1.99-27+deb7u3 amd64 GRand Unified Bootloader, version 2 (PC/BIOS version)
    ii grub-pc-bin 1.99-27+deb7u3 amd64 GRand Unified Bootloader, version 2 (PC/BIOS binaries)


    I managed to do apt-get grub, but the install failed.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!