How to install Seafile with MySQL and SSL


  • also using this command....nano /opt/seafile/conf/seahub_settings.py
    from the tutorial shows an empty file...


    There must be something wrong. The database connection is stored in ~seafile/conf/seahub_settings.py.


    Can you please execupte

    Code
    cat /etc/passwd | grep seaf

    and

    Code
    cat ~seafile/conf/seahub_settings.py



    And you are missing quite a few menu items in the admin menu

  • Hi,


    Thank you all...


    I feel honoured and a little giddy answering to you my Mentors... :)
    Took sometime to prepare this reply because i really did not know where to look for things...



    I had to use the following command to download seafile during the installation...


    Code
    wget https://bitbucket.org/haiwen/seafile/downloads/seafile-server_4.0.6_pi.tar.gz



    since using...


    Code
    wget https://github.com/haiwen/seafile-rpi/releases/seafile-server_stable_5.1.3_pi.tar.gz


    returns a 400 NOT FOUND ERROR




    but comparing an unpacked version of the seafile 4.0.6 and the 5.1.3 for raspberry and also comparing it to the the 5.1.3 generic seafile server for linux (32bit), they all seem to be the same...



    Trying to sort through the problem, as per all your recent instructions...


    1st) I did this


    Code
    su -s /bin/bash seafile


    then


    Code
    cd /opt/seafile/seafile-server-*


    then

    Code
    cd conf


    then do ls -la.... which shows the following list...




    the seahub settings.py where saved to this directory, don't know why...and the contents of which are those of per instructions on page 1 of this tutorial...


    Code
    cat ~seafile/conf/seahub_settings.py

    ..... gives this..






    i noticed another seahub setting.py though ....if i do,



    Code
    cd /opt/seafile/seafile-server-*


    then cd seahub/seahub, then do ls -la, it shows the following content..



    the contents of this 2nd seahub_setting.py are attached as a .txt file... :)







    If i added the following line to this to seahub_settings.py ( the one on the .txt file) :):):)


    Code
    FILE_SERVER_ROOT = ‘https://www.yourdomainname.com:8444/seafhttp’


    and this...to the ccnet conf

    Code
    SERVICE_URL = https://www.yourdomainname.com:8444



    i get a 502 Bad gateway on seafile's web ui if use (=https:// my local ip:8444)... and a 500 Internal server error if i use (=https://my local ip:8444/seafhttp)



    thus, i can only get back the web ui if remove the added FILE_SERVER_ROOT='https://my local ip:8444/seafhttp





    also as instructed doing this...

    Code
    cat /etc/passwd | grep seaf


    shows..

    Quote

    seafile:x:997:100:Seafile Service Account:/opt/seafile:/bin/bash



    Still CAN NOT UPLOAD though..





    thanks very much again my Mentors... :):):)

  • That is quite a bit of information.
    I seem you do have seafile version 4 installed and the configuration files were on different places in that version.
    Do not touch the one you posted and look at ~seafile there you should find the correct seahub_settings.py configuration file

    Code
    ls ~seafile


    the one in ~seafile/conf has been created when you followed the instructions for version 5 by baldman.


    Version 4 does not have the settings admin menu.


  • Please use the following link, you probably got a wrong link from somewhere.
    Releases are published here: https://github.com/haiwen/seafile-rpi/releases


    https://github.com/haiwen/seaf…er_stable_5.1.3_pi.tar.gz


    Try to install seafile 5 with this zip from scratch, using @baldman instructions. They are well defined and tested.

  • In gratitude to you nice mentors........ :)


    after finding the correct seahub_settings.py as kindly shown by zoki...
    i was able to add this...


    Code
    FILE_SERVER_ROOT = ‘https://www.yourdomainname.com:8444/seafhttp’

    as helpfully guided by baldman



    Fixed it... I can now upload with seafile version 4.





    I also wanted to share this...


    no matter what i did, trying to download the 5.1.3 by using the link as generously instructed by sieben..
    I always encountered a 404 not found error, i even tried curl, wget -- no certificate, wget with quotes, git clone....nosuccess



    finally i found the correct link https://www.canox.net/2016/04/…-pi-seafile-installieren/ and i just change the version to 5.1.3
    and download started. :):):)


    Code
    wget https://github.com/haiwen/seafile-rpi/releases/download/v5.1.3/seafile-server_stable_5.1.3_pi.tar.gz


    there is a download directory after the releases directory... :)


    So I am now running seafile 5.1.3 raspbian image on an odroid c1 running on kralizec (no stoneburner for c1 yet though) ....





    To complete the trial, i tried to install seafile on an odroid c2 running on erasmus... and it failed as earlier pointed out by zoki...



    Thanks very much guys for this Great Tutorial .... :)

  • no matter what i did, trying to download the 5.1.3 by using the link as generously instructed by sieben..


    Sorry that I have to correct you, but the link in my post is still correct, as it includes the "download" directory. Maybe you took the wrong one (citation) at the top of my post.


    Nevertheless: the most important thing is you have seafile 5 running ;)


    The installation on your c2 with erasmus should work as well. There is nothing crucial changing in the way of installing.

  • Thanks sieben


    upon reaching the following, on the tutorial...when using erasmus on odroid c2. ...



    Hit enter to finish the Seafile installation



    i get this error message on the terminal....

  • i get this error message on the terminal....


    Just to make sure:
    You installed the needed packages?


    Code
    apt-get update
    apt-get install python2.7 libpython2.7 python-setuptools python-imaging \
    python-ldap python-mysqldb python-memcache python-urllib3


    @baldman btw: I think "python-urllib3" is not yet included in the tutorial ;)

  • Just to make sure:
    You installed the needed packages?......

    yes, i did,... i followed each step on the installation tutorial, carefully...it worked on the odroid c1 (kralizec) but not for the odroid c2(erasmus).


    maybe its because odroid c2 is 64 bit whereas the c1 is 32bit, and the seafile package for raspberry only works for a 32 bit arm processors? ?( as suggested by here


    or maybe its because erasmus on odroid c2 runs on jessie, which has a different init system, and the script might fail, as mentioned by zoki on page 3 of this forum?


    thanks very much again... :)

  • or maybe its because erasmus on odroid c2 runs on jessie, which has a different init system, and the script might fail, as mentioned by zoki on page 3 of this forum?


    thanks very much again... :)

    It is only the init script which might fail, install should be ok.
    The location of the error message is very strage, as it calls the ccnet-init binary, which should be included in the seafile package.
    what is the result of
    ls -l ~seafile/seafile-server-latest/seafile/bin/

  • hi zoki,


    ls -l ~seafile/seafile-server-latest/seafile/bin/



    returns this...

    Code
    root@openmediavault:~# ls -l ~seafile/seafile-server-latest/seafile/bin/
    ls: cannot access /opt/seafile/seafile-server-latest/seafile/bin/: No such file or directory

    i'm fine with the c1 (kralizec) just wanted to know why i can't use this tutorial with the odroid c2 though...


    thanks very much... :)

  • when i issued the command...
    apt-get upgrade


    during the installation this is the output on the terminal...(attached as a text file)




    there are several warnings and errors at the end and file not found errors....hope this helps


    thanks very much :)

  • Hey,


    I installed omv 2.2.5 on an Intel Core2 Duo CPU Mainboard with backport kernel 3.16.0-0.bpo.4-amd64 and my MYSQL plug in does not show a data directory drop down menu....(as shown on my attachment).
    Please help me, thank you.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!