How to install Seafile with MySQL and SSL

  • @tinh_x7 You did not update! There is no seafile-server-5.1.4 directory.
    You have to download and uncompress the seafile 5.1.4 archive and then execute the update script from that version.

    For instructions see "First download and extract the new version." and then follow the steps shown there.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • updating seafile-server-latest symbolic link to /opt/seafile/seafile-server-5.1.3 ...

    You obviously didn't run the right script. This script does not automatically download and update to the newest version.
    You have to download and extract the new version, as @Zoki already said.

    For the upgrade, you have to run the seafile script of the new version, inside the new directory.
    In this case:


    OMV 5.x | Banana PI (M1) | Seafile Server
    OMV 4.x | ShuttlePC SH55J2

    Edited 2 times, last by sieben ().

  • Hi,
    thanks for this guide.

    But I have a problem choosing the right directory for seafile-data.

    How can i get my data-directory on my harddrive and not on the system-SSD. There it puts all my data, when I upload something to my seafile

  • @beneHave you created the /media/[UUID]/seafile directory in the first place and granted rwx permissons for the seafile user?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • I love this community. I've been running OwnCloud 7 since it was released but I've been hearing that Seafile is much better. With no official support anytime near I decided to try Seafile on my VmWare server and no matter what Linux distro I used or guides online I just couldn't get it to work. Then I said hell I'll put it on OMV using your guide and there was not a single issue. Well there is one, for some reason even though I have a valid SSL Certificate from StartSSL the client fails to connect unless I check the box "do not verify certificate" which is odd. Oh well, it's working and now I can do testing.

    Thank you for the great work! Hopefully this is much easier to update than OwnCloud, which is really why I moved on.

  • Let's Encrypt is better than StartSSL, and OMV has a plugin for it too.
    NextCloud has more features and friendlier than Seafile.

    Thanks tinh_x7! I'll give the Let's Encrypt plugin a try. Seafile appears to be much faster than my OwnCloud7 so far from my testing, though the newer NextCloud version probably has improvements. I'll give it a try and compare.

  • Keep in mind to stop seafile,
    extract the downloaded file with the specific user,
    use the upgrade script from the /upgrade directory from the previously extracted folder (e.g. to upgrade from 5.1.3 to 6.0.3)
    check all file permissions
    start seafile.

    and your done.

    OMV 5.x | Banana PI (M1) | Seafile Server
    OMV 4.x | ShuttlePC SH55J2

  • to you nice mentors :)

    i would just like to share how i got around installing seafile on an odroid c2 (64 bit aarch8) which has failed as i mentioned on post 71 on this thread...

    1) installed omv 3.0.13 ISO for odroid c2, and run apt-get update , however there was an error .... NO_PUBKEY 7AA630A1EDEE7D73 that came out...
    I did not get the key and left it as it is, because, if i get the key with.

    apt-key adv --keyserver --recv EDEE7D73

    i could not install plugins anymore.

    Moreso, if I ran apt-get upgrade, it breaks the omv webui and i could not log-in.

    2) to get around the error no2 on seafile installation (the 64 bit/32 bit conundrum), i got the idea from here

    did this...

    dpkg --add-architecture armhf

    apt-get update

    3) a preferences file had to be written, because, the first time i tried this installation, omv broke again, so i copied this procedure from here

    did this...

    nano /etc/apt/preferences

    copy and paste then save this script...

    Package: *
    Pin: release n=jessie
    Pin-Priority: 600


    apt-get update

    4) i then installed libselinux for armhf(32bit) because the second time i tried installing seafile, i got an error...

    /seafile/seafile-server-1.6.0/seafile/bin/ccnet-init: error while loading shared libraries: cannot open shared object file: No such file or directory

    so then i tried this...

    apt-get install libselinux1:armhf


    apt-get update

    After which i continued with the rest of the tutorial on page 1 of this thread.....

    the only hitch i encountered this time was when i issued this from the tutorial...

    /etc/init.d/seafile-server restart

    i get this message from the terminal...

    sudo: unable to resolve host openmediavault

    don't know why,...

    so i tried the following anyway, and i don't know if it is correct...

    service seafile-server restart

    and wooooohooooo!!!!!! it wooooorks!!!!! :)

    thanks very much again!!!!!!

  • Hey guys,

    In the picture from the nginx settings (part four) "port" is selected as host type--> Later on is given as an example.
    Is this just a mistake in the picture and "name-based" should be selected, or am I mistaken and missing something?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!