rsnapshot - questions

  • Sorry guys for having again questions about rsnapshot.

    I have 7 folders on OMV, so I set up 7 tasks for rsnapshot. Target is a second server with two backup-folders mapped via remote-shares. The jobs are running daily - so far ok, it works as it should. Scheduled time is 20:00 (as in /etc/cron.d/openmediavault-rsnapshot defined).

    Here are my questions:

    - Where can I see the jobs on the CLI, where could I change the sequence of the jobs. It seems the sequence is defined by the order of set up?

    - Where can I see in the GUI whether a job is running or has been finished?

    - When I start a job manually from the GUI, a window pops up with "start" and and actual messages, but my GUI is blocked. How can this be changed?

    - With manually start, sometimes statement like this occur:
    rsync: chown "/media/9475796c-....-3d74fa16dca0/remote-shares/backup/DATEN4000/video/daily.0/SAT/Filme/Johnny English - Jetzt erst recht.eit" failed: Permission denied (13)
    What does this mean? Why is rsnapshot (rsync) going to change the owner? I thought rsnapshot itself has admin rights and can copy everything.

    - Why do the rsnapshot-jobs take so long? Even without changes, a new copy of 500 GiB (daily.o --> daily.1) takes approx. 1 hour. Both server on the same switch with Gigabit.

    - In case the backup server is not present, remote-shares is unable to map, but rnapshots nevertheless starts a new backup on place of the designated (empty) mapping folder, what blows up my internal disk. How can this be prevented?

    - And last but not least, is there a better way to make daily, scheduled, differential backups? Sorry, I am spoiled by Time-Backup (Synology), that is fast, reliable and gives a clear statement via mail whether the backup was successful.

  • Remote shares is your first problem. I'm guessing you are connecting to a samba share? Too hard to get the permissions right to use.

    You can't change the sequence. Not sure why you want to. rsnapshot is designed to run hourly, daily, weekly, etc. You can change the time by editing the cron job.

    There is no status in the gui unless you look at the process list. Do you not believe it is running?

    I don't know what "gui blocked" means??

    Remote shares is your problem with permissions.

    Take so long?? Lots of small files? Slow server? 500 GB is a large job. Once again, if you are using remote share, it might think the files are different and recopy them. rsnapshot uses hard links which I am not sure if samba supports or how well it supports.

    This is a problem that is hard to fix...

    I rsnapshot to a different drive on the same server. Then I rsync to my backup server using rsyncd. No mounts to worry about and permissions/links are all linux compatible. Your synology box should support rsync. rsnapshot and rsync both send emails when complete as well. You need to have notifications setup.

    I have had better luck with rsync/rsnapshot than anything by Synology or QNAP. Trust me I have tried everything over the years.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I like rsnapshot, together with remote-shares it does what I want. So my questions are a summary of my experience the last eight weeks, because I like to understand how it is going and to avoide beginner faults.

    remote-shares - Was a recommendation of subzero and you. I put in on samba, for some reason I doesn't understand, I was unable to switch on nfs on the same hardware setup. But as samba worked I did not further investigate in the nfs-issue .
    Does it make sense to go for nfs instead of samba? What would be the benefits?

    Sequence and manual starting the job is nice when initially filling. Its hard to figure out rsnapshot in the process list, as it starts rsync the same time.

    "gui blocked" - When starting rsnapshop manually from the gui, a window pops up with two options "Start" and "Stop". After manual start the gui waits for finished or manual "Stop". Anything else of omv-gui is left behind unreachable.

    Even with the wrong permissions of remote-shares, the copy is running with all files. Again, would nfs help to avoid these permission warnings?

    Samba supports hardlinks, otherwise the utilization of the disk would blow up. Time-Backup was way faster, maybe they use some kind of database in the back what speeds up. But if there isn't a switch "slow-medium-fast", I did not find yet, I can live with that.

    rsync after snapshot whould generate two copies of the original. rsnapshot on remote-share gives one incremental copy on a seperate server. That's better for me.

    The problem with the process list, email notifications aso is not lack of information. It is too much information, where the important messages are difficult to find.

  • I don't remember recommending using rsnapshot to a remote-share connected samba share. I have tried that in the past and it just has a lot of issues. I wrote most of the remote share plugin but I stopped using it because it isn't the right way to do things in OMV.

    GUI Blocked - this is how OMV does everything that you manually run. If it is an issue just open another OMV window. You can be logged in more than once.

    I have no idea if NFS would help. Try it.

    Rsync transfer between servers is still the best (and fastest for me) method in my opinion. The notification email has the perfect amount of information as well. One extra copy of the files is a good thing in my opinion.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!