System resumes directly after autoshutdown performs suspend

  • Hi,
    I have a clean installation of OMV and was trying to use Autoshutdown.
    I have configured it so it seems to init a suspend to RAM. But everytime it goes to sleep it seems to wakeup only a few seconds later. At least I am seeing new entries in the autoshutdown log. (See attachment)


    I want to wake the system up at some time of my choice, but not automatically this way ^^
    Are you having any idea on how to find out, what causes this auto-resume? Or maybe it's something else I am not seeing here...


    Cheers Maik

  • I would make sure you are running the backports kernel (new, better suspend support) and I would check your bios/efi settings.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Things having to deal with sleep/suspend/etc. Not saying something is wrong but just thought the settings should be checked.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • OK, will check that.
    In the meanwhile I have used


    Code
    tail -f /var/log/pm-suspend.log


    while executing


    Code
    pm-suspend


    and it brings me the following. Seems like at 21:33:14 suspend was successful and 4 seconds later it gets awake. Or does the entry mean suspend action returned with code "awake" and it tries to resume?


  • Do you have a network card Realtek? If so, does it have WOL enabled ?


    the card can be checked with lspci -nn



    WOL is enabled:

  • I can speak for me, as I have also a Realtek card, this is "normal" behaviour. Shitty driver ? Probably. To the day I still don't know if this is a problem with the kernel module or the card blob firmware. I also haven't check upstreamif this has been patched so that I can backport it.


    If you can live without WOL, try to disable in bios and in the network setting in omv. See if it behaves properly.
    if you have a spare pcie slot, try and get and Intel card.
    i dont use auto shutdown , but my server goes to suspend at certain tIme, I have to schedule the job twice under two minutes for it to go down.

  • I can speak for me, as I have also a Realtek card, this is "normal" behaviour. Shitty driver ? Probably. To the day I still don't know if this is a problem with the kernel module or the card blob firmware. I also haven't check upstreamif this has been patched so that I can backport it.


    If you can live without WOL, try to disable in bios and in the network setting in omv. See if it behaves properly.
    if you have a spare pcie slot, try and get and Intel card.
    i dont use auto shutdown , but my server goes to suspend at certain tIme, I have to schedule the job twice under two minutes for it to go down.


    Will this still be a problem with OMV 3.x? Or might that be fixed there (newer drivers available...?)
    Autoshutdown would be great for a NAS Media Server running only when needed (wol) and suspending when not :(
    I will check tomorrow if disabling WOL in BIOS will have an effect on suspending.

  • system


    If the system is shutdown, how is going to log?
    this is not a problem with something sending wol packets, is a bug in the card.
    Sometimes can happen if you have kodi, and you leave a movie paused overnight then the server is next day awake, because kodi sent wol package because it is instructed to do so.


    if you want log wol packets you have run tcpdump n the bridge switch interface in the router

  • I have an ASUS F751LDV which restarts on its own after "shutdown now", "init 0" and even after resetting with the power button. The only way to not letting him restart instantly is by pulling the power cord and pluggin it back in. This way it stays off. I can wake it up via WOL then.


    The only way to switch off automatic restarts is by enabling "Power off energy saving" in the BIOS which as a side effect has "The wake up capability might not be workable".

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!