Neuling verzweifelt an OMV

  • Ich hatte Daten kopiert, plötzlich hat er den Kopiervorgang abgebrochen und ich konnte nicht auf die Freigaben und auch nicht auf die WebGUI zugreifen (bis ich einen manuellen Neutstart ausgeführt habe)
    Das hatte ich gestern 2x hintereinander, seitdem nicht mehr.


    In das Syslog hatte ich reingeschaut, aber da waren nur Daten von nach dem Neustart drin.



    Gruß

  • So gerade ist der Fehler wieder aufgetreten, wieder beim Daten Kopieren.
    -Freigaben und WebGUI nicht erreichbar
    -ping (über cmd an die IP) gibt "Zeitüberschreitung der Anforderung (100% Verlust)
    -Daten nach manuellen Neustart: keine, komme gerade auch danach nicht rein.

  • @Ch3fk0ch Von wo nach wo kopierst Du Daten? "Innerhalb" des OMV oder von einer SAMBA-Freigabe auf das OMV-NAS; sorry, auch hier kann die Ursache für Fehler liegen. Meistens sitzt der Fehler zwischen Bildschirm und Tastatur ... ist nicht persönlich gemeint!!


    Es gibt Kopien vom syslog, heißen dann syslog.1, syslog.2.gz, syslog.3.gz, usw., guck bitte auch dort rein. Wenn Du an die OMV-Maschine einen Bildschirm und eine Tastatur angeschlossen hast kannst Du auch auf diesen Bildschirm schauen, wo genau das System stehenbleibt. Machst mit dem Smartphone oder der Digicam davon ein Foto und stellst es hier herein. Screenshots vom GUI mit den Festplatten und den Dateisystemen wäre auch hilfreich.


    Es ist ganz sicher, dass es in Deinem Netzwerk nicht noch einen DHCP-Server gibt außer den in der Fritzbox?
    Viele Grüße.

  • Mir ist schon klar das der Fehler bei mir liegen kann, ich bin Maschinenbau Ingenieur und kein ITler xD


    Ich kopiere die Sachen mit SAMBA Freigabe wie folgt eingestellt:


    Benutzer mit den Gruppen (adm, sambashare, users)
    Unter SMB/CIFS ist nur Lesen überall "Nein" und alles freigegeben
    Unter Privilegien ist für den Benutzer überall Lesen/Schreiben und bei der EXT4 Platte auch bei ACL


    So funktioniert das, halt nur das er ab und an abstürtzt.


    Gerade ist auch das neue Netgear Switch angekommen.
    Mal schauen ob es mit dem besser geht.



    Ich hab das Syslog mal angehängt, der Fehler müsste irgendwo bei 14:55Uhr sein.



    Gruß

  • @Ch3fk0ch
    Hey, habe mir das syslog angeguckt. Zeile 635 bis 640 sagt aus, dass der Netzwerkchipsatz ein r8169 ist. Hier wurde von einigen Usern von Problemen mit Realtek-Netzwerkkarten bzw. -Chipsätzen berichtet. Ein User hat vor einigen Tagen ein kleines HowTo hier ins Forum gestellt, wie er einen aktuellen Treiber für Realtek-Netzwerkchipsätze installiert hat. Hier könnte man versuchen, zunächst einen Backport-Kernel zu installieren und dann das System erneut zu testen. Dann vielleicht das Posting dieses Users mit dem HowTo raussuchen ... habe ich eben mal gemacht:


    Windows-Backup schießt Samba ab?


    und dort im weiter Thread


    Update NIC driver Realtek R8169


    Das eigentliche HowTo steht hier im Thread:


    AM1 motherboards w/ Realtek RTL8111GR LAN, any luck?


    Ein weiterer Ansatzpunkt wäre in den Zeilen 1875 bis 1879 zu finden, hier ist von einem Adresskonflikt die Rede. Man könnte deshalb der OMV-Maschine eine IP-Adresse außerhalb der DHCP-Range geben (statische IP-Adresse), dazu den Standardgateway und den DNS-Server eintragen (jeweils die IP-Adresse der Fritzbox). Die "Abstürze" können IMHO nur durch Netzwerkkonfigurations-Probleme verursacht werden, daran werden vermutlich neue oder andere Netzwerkkomponenten nichts ändern.


    BTW: Ich war mal Schlossermeister, bin jetzt Rentner; auch kein IT-ler. :)


    Viele Grüße.

  • @Ch3fk0ch Hey,
    ich habe mir gerade die specs Deines Mainboards angesehen, nun bin ich mir ziemlich unsicher geworden.


    LAN
    Realtek® RTL8111H, 1 x Gigabit LAN Controller(s)


    Das ist zwar auch ein Realtek-Chip, ich weiß aber nicht, ob der aktuell vom Kernel unterstützt wird.Ein Backport-Kernel ist der aktuellste, den es gibt, weil der von Debian-Jessie auf die OMV-2.x.x-Basis Debian-Wheezy zurückportiert ist. Wenn dort keine Treiber für Deinen Chipsatz drin sind, kann das dauerhaft zu Problemen führen. Aber probieren sollte man es allemal!


    Viele Grüße.

  • Hi,
    ich kopiere gerade 1TB um das mit dem neues Switch zu testen.
    Anschließend wollte ich den Backport-Kernel draufspielen.
    Das Problem ist, dass der Fehler zufällig auftritt.


    Habe ja 2 Wochen Zeit um es zu testen.
    (was wäre den ein Motherboard welches ohne Probleme funktioniert?)

  • Hey,
    das Motherboard ist nicht das Ausschlaggebende, wichtiger ist der Netzwerkchipsatz der da drauf ist. Viele User hier im Forum berichten über Probleme mit Realtek-Chipsätzen (brauchst nur mal im Forum nach r8169 suchen). Die Admins z.B. tekkb oder ryecoaaron schlagen Intel-NIC vor, die wären am wenigsten problembehaftet. Ich habe hier auch den Onboard-Netzwerkchip deaktiviert und eine Intel-Netzwerkkarte eingebaut. Das soll aber nicht heißen, dass Du das auch so machen musst! :-) (In diesem Zusammenhang stimmt meine Signatur nicht, das betrifft eine andere OMV-Maschine, meine Test-Kiste.) Probier ruhig erstmal den Backport-Kernel aus, ich hänge einen Screenshot an.


    Ein weiterer Anlaufpunkt auch zu OMV und verwendbarer Hardware wäre ein anderes Forum; ich weiß nicht ob der Link dorthin hier gern gesehen ist. Googlen nach "technikaffe" sollte genügen ...
    Viele Grüße.

  • Hey,
    wenn das mit dem Backportkernel immer noch nicht klappt, weil Instabilitäten bzw. Abbrüche auftreten, kannst ja noch wie schon weiter oben beschrieben nach dem Link vorgehen:


    AM1 motherboards w/ Realtek RTL8111GR LAN, any luck?


    und wenn auch das nicht zum gewünschten Erfolg führt, kannst Du immernoch eine andere (Intel-)Netzwerkkarte in Dein System einbauen, sofern Du in den PCI-Express-Slot keine Grafikkarte oder andere Karte eingebaut hast. Je nach Gehäuse-Bauart gibt es auch low-profile-Karten ... BIOS-Update ist auch eine gute Idee, wird Dir aber sicherlich nicht bei Deinem Problem weiterhelfen.


    Bitte mach BEVOR Du das Treiberupdate wie im Link vorgeschlagen ausführst ein Backup Deines OMV-Systems!
    Viele Grüße.

  • @Ch3fk0ch
    Anderes Thema: Festplatten nach und nach hinzufügen --- geht nur mit RAID 5 oder 6, nicht mit linear oder stripe. Du könntest - rein theoretisch - mehrere Dateisysteme auf Deinem OMV anlegen.
    Einmal das mit der 4TB-Platte, dann eines mit den 3 2TB-Platten (die müssen aber vorher leer sein, sonst Datenverlust!!!) und eines mit der einen 1TB-Platte, die Du vorher auch leergezogen hast. Das Dateisystem mit den drei 2TB-Platten könnte dann sogar ein RAID5 werden ... Alles "zusammenziehen" auf ein 11GB-Linear/Stripe (JBOD)-System geht NUR mit leeren Platten ohne Datenverlust.


    Heißt also: wohin (vorübergehend) mit den Daten??? Ich erkenne Dein Problem, kann Dir aber leider keine Lösung anbieten. Du kriegst eben die 6 TB von den drei 2TB-Platten nicht irgendwo anders hin"gequetscht".


    Viele Grüße.

  • Ist da noch Garantie drauf? Frag mal nach der Seriennummer und guck bei Seagate nach ... oder lass Dir wenigstens die SMART-Werte durchgeben.


    Weißt Du, mir geht es immer um die Sicherheit Deiner Daten. Auf den einen oder anderen heruntergeladenen Film oder diese oder jene TV-Serie kann man notfalls verzichten, aber auf selbsterstellte Projekte nicht. Deshalb nützt Dir auch eine relativ günstig eingekaufte gebrauchte Platte nichts, wenn das Risiko des Datenverlustes groß ist. Ist die Desktop-Platte 24/7 gelaufen, vll. in einem NAS? Einen Haufen heruntegeladener MP3 kann man verlieren, selbstgemachte Musikclips oder gesampelte eigene Musik sollte man nicht verlieren. Auch sind die Familienfotos und -Videos manchmal unersetzlich.


    Viele Grüße.

  • Mir ist schon klar das der Fehler bei mir liegen kann, ich bin Maschinenbau Ingenieur und kein ITler xD


    Das ist eher von Vorteil als von Nachteil.


    Hier noch ein paar Erfahrungen aus meiner Lernkurve:


    Nach der Erstinstallation musste ich auch größere Datenmengen verschieben. Jeder hat da seinen individuellen Lösungsansatz. Meiner basiert darauf, dass es mich anfangs sehr störte, in OMV den Inhalt meiner Platten nicht zu "sehen". Und mit extplorer konnte ich mich nicht anfreunden.
    Bei mir folgende Vorgehensweise:
    - Erstinstallation OMV mit der "Zieldatenplatte" und den notwendigen "Benutzer", "Freigegebene Ordner" und "SMB/CIFS"s. In Windows sollte alles erscheinen, natürlich leere Ordner.
    - Die alten Datenplatten ans System anschließen, aber lediglich bei "Dateisysteme" einhängen.
    - SSH aktivieren, und unter Windows mit putty auf den Server zugreifen.
    - mit "apt-get install mc" den MidnightCommander installieren.
    - mc starten und darin die Daten kopieren, also quasi auf Debian-Ebene. Alle Deine Festplatten findest Du unter /media (sollten die UUID zu kryptisch sein, Symlink setzen). Das hat den Vorteil, dass es sicher ist, unabhängig vom Windowsrechner (der kann während des Kopierens ausgeschaltet werden) und am schnellsten ist, da es von Bus zu Bus geht, ohne Netzwerkkarte o.ä.
    - Möglicherweise stimmen anschließend bei den Freigaben die Rechte nicht. Das kann in der OMV-Webgui bei "Freigegebene Ordner" - "Berechtigungen zurücksetzen" in einem Rutsch korrigiert werden.
    - Nach dem Kopieren kannst du die alten Datenplatten aushängen, ausbauen oder neu formatieren.



    Wenn ich größere Datenmengen über die Samba-Freigaben kopiere, nutze ich nicht die Windows-Kopierfunktion, sondern Sync-Software wie SyncBack Free. Irgendwie klappt das besser (Bauchgefühl).



    Zu RAID:
    Nach meinem Verständnis hat RAID mit Verfügbarkeit, Ausfallredundanz und Geschwindigkeit zu tun. Nicht aber mit Datensicherheit oder Backup. Für den Heimanwender sehe ich keinen Vorteil. Daher sind alle Datenplatten bei mir ohne RAID direkt angeschlossen. Sollte mal der Server abschmieren, kann ich jede Platte an jeden Linuxrechner hängen und die Daten auslesen. Mit einem korrumpierten RAID ist das wesentlich schwieriger.
    Als Backup dient ein zweiter Server (ne alte 1-Bay-Synology) mit einer 8TB-Seagate Archiv auf der alles Wichtige direkt aus OMV versioniert gespiegelt wird. Die Windowsrechner haben i.A. keinen (Schreib-)Zugriff auf dieses Backup.
    Weitere externe USB-PLatten nach individuellem Sicherheitsbedürfnis.



    Kodi nutze ich nur mit Samba-Freigaben. Bisher keine Probleme.



    Die Hardware muss natürlich passen. Sollte da wirklich eine Netzwerkkarte nicht mitspielen, muss der Fehler natürlich lokalisiert werden. Da helfen die Kollegen weiter. Nach meiner Erfahrung kommen aber die meisten "Fehler" daher, dass man sich bei der ursprünglichen Fehlersuche immer mehr verkonfiguriert. Die Grundeinstellungen von OMV passen eigentlich.


    Viel Erfolg noch!

  • @erik Alles richtig, sind sehr gute Hinweise dabei.
    Nur: Ch3fk0ch hat das Problem, seine vorhandenen 7 TB Daten auf die neu gekaufte 4 TB-Platte im OMV zu "transferieren", dafür hat er diese insgesamt 4 Platten mit den 7 TB Daten und die leere 4 TB-Platte in den OMV eingehängt. Nun heißt es "hin- und her- schaufeln", bis ein 11 TB-JBOD-System entstanden ist.Oder so wie Du es vorschlägst, jede Platte einzeln einzubinden; aber das hat doch Ch3fk0ch schon gemacht! Das will er doch nicht, jedenfalls habe ich das bisher so verstanden.


    Guter Hinweis: ich benutzte bisher Teracopy, das SyncBack Free gucke ich mir an. Danke.


    Viele Grüße.

  • Klar ist das praktischer als die ganzen "kleinen" Platten. Wenn Du damit leben kannst, mehrere Quellen in Kodi einzubinden und alles ein wenig "zertragener" ist, sicherlich vorübergehend eine gute Lösung, die kleinen Platten einzeln einzubinden.


    Irgendwie befriedigt mich diese Lösung mit den einzeln eingebundenen Platten noch nicht so ganz. Vielleicht lassen sich zukünftig mehrere Platten zu Dateisystemen zusammenfassen. Kommt eben auf die Datenmenge an.


    Kommt es dazu, dass Du dir noch eine 4 TB-Platte kaufen kannst und in den OMV einbaust, geht die Schaufelei von vorne los.Aber was solls; man hat doch (jeder von uns) dazu gelernt.


    Zurück zum Netzwerkproblem: schreib bitte wieder hier, wie das weitergegangen ist, ob Problem gelöst oder nicht.


    Viele Grüße.

  • mach ich,
    ich schiebe einfach ein paar Daten zwischen den Platten hin und her^^


    Sollte der fehler dennoch auftreten werde ich das MB tauschen, da so eine Netzwerkkarte 35€ kostet und das Motherboard 70€ wobei ich da halt das alte zurückgeben kann^^

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!