Amazon Clouddrive plugin

  • Thanks for the info @bug11. At the duplicati homepage I've seen a debian package (the same as for ubuntu too) so at least for debian jessie (OMV v3) you can use this package. Unfortunately there isn't one for Wheezy (OMV v2). So I guess you mean with docker when you use OMV2?


    Edit: and is it possible to automount my amazon cloud drive with duplicati so that I can use it like an internal/local drive? And will everything crypted when I copy data to this drive?

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

    Edited once, last by Huberer ().

  • Thanks for the info but first I've to learn how to work with docker. I've never done that before.


    Edit: after a long search I could install docker on OMV3. Because of your info @bug11 you posted in another thread I had to enable both docker repos (normal/stable and testing one) to install docker. With the "stable" repo "docker" didn't show up under extensions to install.


    Another question. Which duplicati version do you recommend? v1.3.4 or 2.0?

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

    Edited once, last by Huberer ().

  • Thanks, I found out to install docker and duplicati. Tomorrow when I'm back in the office I will do the rest of the test to find out how everything works.
    Thanks for your assistance.

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • @bug11


    I think I'm too stupid for docker. I can't find any how-to for a noob like me which contains images to follow. The how-do's are very complicated explained.
    Would you be so kind and say what I've to add here:




    because when I start without adding something I will receive the error log:



    Code
    ERROR- DUPLICATI_PASS must be defined
    Init process in progress...
    /entrypoint.sh: ignoring /docker-entrypoint-init.d/*

    and this message continues regularly.


    I hope you can help me in this matter. Thanks in advance.

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • Sure:


    I would set Networking to Host, to keep things simple. if not, port forward port 8200 (-p in description in dockerhub).


    In environment you put "DUPLICATI_PASS" in left column, no "".
    Corresponding right column you put "duplicatiPass", again no ""



    in path, you add your folder which has read/write access.
    and then "root/.config/Duplicati/" as corresponding folder. This will be Duplicati config folder, all settings are saved here. in case of reinstall, just point to same folder and config loads as before.


    and then you find folder you want to backup and add /data as corresponding folder. The /data is the mountfolder inside duplicati docker image.


    That should be it.

  • btw, hint:
    I gave up as well - to complicated, i need a reliable solution to get my encrypted files uploaded.
    I decided to purchase syncovery (linux version also available), which is able to mount/upload to cloud
    storages directly, which can upload incrementally, compress, encrypt, etc...

  • Thanks, will give that a try and will let you know. Thanks

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • @bug11


    Now, I've made the settings you suggested. This is how it looks like now:





    Ok, I know about the password, I have to use a special one. By typing "no" (without the question marks) I have to enter no into the password-field to enter webif. If I leave these settings blank than I can't start duplicati because of the missing password.


    About the path's I'm not quite sure. I chanced the setting in "HOME" under "Environement variables" from /HOME to "root/.config/Duplicati/" but automatically this setting is also changed/entered under "Volumes and Bind mounts" => "Host path". Is this correct? When I delete this setting in "Volumes and Bind mounts" after a new start this entry is back again. Also I didn't enter the setting "/docker/entrypoint-init.d" in "Host path". Do you know why it is like that?


    The other setting in "Host path" is "/media/aaad84ac-fd19-4c0f-90a9-47f796e4609e/Amazon. This should be the folder where all the data should go and backed up to amazon cloud drive.


    And do you know how do update duplicati? When I enter the webif I'll get the message that an update is available. The answer is simple. Just to click update in the webif, restart duplicati and voila....


    thanks in advance
    Huberer



    Edit: I could make a backup but I don't know if duplicati is the program I want to use. I want to add amazon cloud drive to my server as integrated drive so I can use it for emby or for plex as data drive. How is this possible? Right now I only can understand that duplicati is cloning my data from the internal drive to ACD so that I have everything double. Do I understand that correct or not?

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

    Edited 2 times, last by Huberer ().

  • I created a duplicati plugin for OMV 3.x. It is very simple and uses the duplicati web interface. Try it out.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Listen Address: 127.0.0.1


    It gave me a blank page.

    If you tell it to listen on 127.0.0.1 (which is localhost), then you can only connect to the web server from localhost (possible with remotedesktop plugin). If you want to connect to it from any other system, follow the note and put 0.0.0.0 in the field. There are plenty of other plugins that follow this same idea.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I use 127.0.0.1 for Mysql, and connect it on my laptop fine.

    That field in mysql is for mysql not the admin web interface. So, you can connect to the admin web interface but you can't connect directly to mysql with that setting. You must only use mysql apps on the server itself.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!