Amazon Clouddrive plugin

  • Is it possible to choose the source data from my Windows drive or folder?

    If you share it on the Windows box and the mount it on the OMV box with remotemount or manually from fstab. You would be better off to have the windows box copy/backup the files to the OMV box though.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Is Duplicati Plugin only for makeing a Backup of the OMV-Server to a different storage? It can't be used with the Duplicati-Program for Windows?

    The same program runs on Linux that runs on Windows. So, they do the exact same thing. You can backup remote data *if* the remote data is mounted on OMV (remotemount plugin).


    You could use duplicati on OMV to backup to the cloud and use duplicati on Windows to backup to your OMV server and/or to the cloud.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I tried to backup on Google Drive & One Drive, but none of them work for me after several attempts.

    I am new to duplicati myself. So, I can't answer many questions. Maybe asking on the duplicati would be a better choice?

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I created a duplicati plugin for OMV 3.x. It is very simple and uses the duplicati web interface. Try it out.

    Hello there!!!!! first at all sorry for my poor english! im new in this world of linux & OMV, im very interested to install your plugin but i cant find it at the web ui, im runnig OMV on a rpi 3, with this plugin i can sync a Omv local folder with my Amazon Cloud Drive?




    Thank You very much!!!!


    Gabriel

  • im very interested to install your plugin but i cant find it at the web ui, im runnig OMV on a rpi 3

    Fixed now. Click the apt clean button in omv-extras and it should show up in the plugin list after that.


    with this plugin i can sync a Omv local folder with my Amazon Cloud Drive?

    Yyes. Although I couldn't get it to work with my account. If you can't get it to work, you will probably need to ask what is wrong on their forum.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Fixed now. Click the apt clean button in omv-extras and it should show up in the plugin list after that.

    Yyes. Although I couldn't get it to work with my account. If you can't get it to work, you will probably need to ask what is wrong on their forum.



    thanks Again!

  • I didn't test on the RPi. Raspbian (which the RPi uses) may not have the right mono packages in its repo. Enable the mono repo and see if you can install it.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I didn't test on the RPi. Raspbian (which the RPi uses) may not have the right mono packages in its repo. Enable the mono repo and see if you can install it.

    nop! cant install, but thank you so much!!! this plugin its so good to be true!

  • Hi,


    i also want to do a cloud backup solution.
    For amazin is there a limitation for the upload speed from amazon?
    I read something in the web that amazon in doing an upload speedlimit at 2mbit.
    But other threads in some other forums are not reporting such a limitation.


    Cheers Robert

    OMV 5.x always up to date.
    Modded dell t20 into 19" rack case with Pearl LCD Display (Status Display!)

    xeon e3-1225v3 / 32GB RAM / 1x500GB WD Blue SSD (OS) / 1x250 SSD (not used) / 1x1 TB Toshiba HHD (MultiDisk) / 4x 4TB WD40EFRX (Raid5)

  • I have installed Duplicati on OMV 3 and I can start it but I am unable to backup to either Onedrive or Mega. I keep getting an error when I test the connection and it doesn't mater if I use Onedrive or Mega. The error message is "Failed to connect: The server certificate had the error RemoteCertificateChainError... You may want to import a set of trusted certificates into the Mono certificate store. Use the command: cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems"


    I have tried to run the command on my OMV server but I only get unknown command. I have enabled the Mono repo.


    Any help would be appreciated


    Markus

  • The server certificate had the error RemoteCertificateChainError... You may want to import a set of trusted certificates into the Mono certificate store. Use the command: cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems"

    When you are adding the cloud service, there is an option on the screen right below to add the cert. No need to do anything from Linux command line.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • When you are adding the cloud service, there is an option on the screen right below to add the cert. No need to do anything from Linux command line.Got

    Today on my lazy sunday, I was browsing the new OMV plugins and was very happy to find the new duplicati plugin.
    Unfortunately, I ran in the same problem that was described by tylerism.


    I've read your answer ryecoaaron, so first of all: Thanks for caring! But Sorry, there are two disadvantages in using the advanced option with -accept-specified-ssl-hash=<ENTER CERT HASH HERE>:

    • It will not work, as the hash code changes every time you use the "check connection" button. Probably M$ uses different redundant servers for accessing their services and therefore there are different certificates which equals different hashes.
    • From a security perspective, it is not the best idea to create some accept rules for unknown certificates as this is not the way certificates are intented to work. The proper solution would be to verifiy the chain of trust trought the root and intermediate certificates. What the mono-specific command cert-sync /etc/ssl/certs/ca-certificates.crt would do is to download the root and intermediate ceritificates from a trusted source, so tylerism's way is the most common and secure solution. Actually, I have no idea why this command is not working on an "usual" omv installation. Perhaps anyone else in the space out there? :)

    Added infromation: I just found the thread about the Amazon Cloud Drive certificate error and I think the different (older) duplicati version is likely the core issue here. I'll try to add the mono-repo and will test again.

    Edited once, last by Ener: added new information ().

  • But Sorry, there are two disadvantages in using the advanced option with

    I realize that but you are quoting an old post. There is another thread where I made changes to the plugin to download the certs from the trusted source using mozroots - commit

    What the mono-specific command

    cert-sync doesn't work on the debian version of mono since it is too old.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I realize that but you are quoting an old post. There is another thread where I made changes to the plugin to download the certs from the trusted source using mozroots - commit

    Yes, I've realized later that your post is from january. Thanks a lot for the hint with the commit! But just to be sure: I've to download the certs with mozroots manually, right?


    Edit: Got it, this should be the post you mentioned: Duplicati failing to see content - [SOLVED]

    cert-sync doesn't work on the debian version of mono since it is too old.

    Got that. Thanks a lot and once again: You guys are doing a great job with all these plugins!!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!