Login am GUI nicht möglich

  • Hallo,


    ich kann mich nicht mehr anmelden.
    Was ich alles schon versucht habe:
    -Browser-Cache und -Verlauf geleert
    -verschiedene Browser verwendet
    -andere Clients im LAN zur Anmeldung versucht
    -die Suchfunktion malträtiert und nichts brauchbares gefunden


    Es kommt wie auf dem angefügten Bild zu sehen ist kein Anmeldefenster:


    Könnt ihr mir bitte helfen?
    Viele Grüße.

  • Hey alle,
    alles schon versucht.

    Code
    Last login: Sun Apr 10 12:57:04 2016 from gigabyte-quad.fritz.box
    root@FSC:~# service nginx restart
    Restarting nginx: nginx.
    root@FSC:~#


    omv-firstaid -> Configure WebGUI -> Ports neu eingestellt usw. usf. -> erfolglos (von "zurücksetzen" steht dort nichts)


    IP-Adresse statt "Name" -> wie auf dem angefügten Bild zu sehen ebenfalls erfolglos.


    Das kann es doch nicht sein!! Hier sollten die Entwickler mall einen gewaltigen Scheit auflegen, BEVOR sie sich auf 3.0.x stürzen.


    Das letzte mal, als ich diesen Effekt mit dem nicht vorhandenen Anmeldefenster hatte, war Mitte vorigen Jahres (SuFu), damals hatte nur ein vorher hergestelltes Backup zum wiederaufsetzen geholfen. Innerhalb eines Jahres sollte doch dieser Fehler definitiv beseitigt werden können. Scheint aber doch nicht so zu sein.


    Bitte her mit allen euren Tipps, vielleicht kommt doch noch was zum Vorschein, was dieses Problem zu beseitigen hilft.


    Viele Grüße und danke.

  • Hallo omavoss,


    Problem inzwischen gelöst?


    Ich schmeiß noch einen Tip in die Runde: Nachdem was ich hier so lese (keine eigene Erfahrung), kann es Probleme mit dem Anmelden geben, wenn aus irgendeinem Grund das Root-Verzeichnis vollgelaufen ist.
    Wenn Du Dich mit ssh anmelden kannst, check das mal. Noch besser, in MC auf der CLI direkt prüfen, ob irgendein Download- oder Kopier-Script statt auf einen Share auf einen lokalen Ordner gespeichert hat und den Rotz weglöschen.


    Alte logs können auch weg (rm /var/log/*.gz)


    Vielleicht hilft das weiter
    Erik

  • Ja, habe ich schon versucht. Ich hatte auch den Verdacht, dass root voll ist.


    putty wirft aus:



    Jetzt weiß ich nur nicht, was ich wo löschen kann, ohne Datenverlust befürchten zu müssen ...

  • @Zoki

    Quote

    Als erstes würde ich /var/log schauen, und alle alten archive löschen bzw. nach media/ff37ba74-4584-4f74-9dab-265197e72994 verschieben.



    @erik

  • Hey alle,
    habe alle log-Archive gelöscht, trotzdem negatives Ergebnis.


    putty wirft aus - ich kann nicht alles pasten weil die Ausgaben nicht seitenweise anzugeben sind und so nicht von Anfang an darzustellen gehen:


  • so spekulieren wir mal:


    /media/ff37... ist unkritisch (3TB, halbvoll)
    /by-uuid/3d76... ist voll, hier scheint das Problem zu liegen.


    Laut Footer liegt (system) auf einer 10GB HDD, auf ner 80er USB-HDD liegt data-owncloud. Allerdings liegt Dein "/" auf einer 71 GB-Partition, der 3d76.... (71 GiB = 80GB?). Ne 10GB-Hdd sehe ich nirgens. Dafür noch 4Gb (wahrscheinlich ram (?), da sind nur einige Ordner unterhalb von /var/ (folder2ram)).


    Kann es sein, dass Dein ganzes OMV auf der 80er USB liegt und diese mit owncloud vollgelaufen ist (vielleicht versioniertes löschen). Falls ja lösch was von owncloud und schau, ob die 3d76... leerer wird.

  • Das kann es doch nicht sein!! Hier sollten die Entwickler mall einen gewaltigen Scheit auflegen, BEVOR sie sich auf 3.0.x stürzen.


    Mal ruhig oma. Für ein vollgelaufenes rootfs war noch -nie- ein Entwickler schuld. Das ist entweder owncloud, ein eigens verkonfigurierter rsync oder überlaufende LOG Dateien.


    Bitte mal folgendes posten, dann arbeiten wir uns langsam vor.
    ls -hal /

  • Hey alle,
    habe alle log-Archive gelöscht, trotzdem negatives Ergebnis.


    putty wirft aus - ich kann nicht alles pasten weil die Ausgaben nicht seitenweise anzugeben sind und so nicht von Anfang an darzustellen gehen:


    Das war leider nichts, hier fehlt der entscheidende Teil, nämlich das Verzeichnis auf /, das die ganzen Daten enthält.


    Leite die Ausgabe doch bitte in eine Datei um und hänge das hier an.


    Quote

    du -h -d 3 / | sort > /tmp/disk-usage.txt


    Irgendwo müssen die Daten ja liegen.

  • @WastlJ Ja das stimmt, dafür können die Entwickler nichts. WENN das root-fs vollgelaufen ist! Das scheint ja hier auf meiner OMV-Maschine der Fall zu sein, aber WARUM kann das überhaupt vorkommen? Denn @votdev die Maschine kennt keine e-mail-Adresse, wo sie eine Nachricht hinschicken könnte. Demzufolge ist auch keine Nachricht irgendwo aufgeschlagen, die auf ein Vollaufen des root-fs hindeuten könnte.


    Wenn ich gewusst hätte, wo die Ursache liegt, dass das Nichteinloggen können auf ein vollgelaufenes root-fs zurückzuführen ist, hätte ich nicht einen solchen "Aufstand" hier verursacht, sondern wäre ganz still in mich gegangen und hätte die Ursache selbst versucht herauszufinden. Insoweit war es für mich und wahrscheinlich auch für andere doch ganz nützlich, auf das Problem aufmerksam gemacht zu haben. Ein Hinweis z.B. "Achtung! Dieses Plugin kann vollaufen des root-fs verursachen! Deshalb die monit-e-mail-Benachrichtigung richtig konfigurieren!" oder so in der Art wäre schon ganz nützlich gewesen.

    @Zoki
    es kommt ein Fehler:


    Code
    root@FSC:~# du -h -d 3 / | sort > /tmp/disk-usage.txt
    du: Zugriff auf „/proc/13429/task/13429/fd/4“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    du: Zugriff auf „/proc/13429/task/13429/fdinfo/4“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    du: Zugriff auf „/proc/13429/fd/4“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    du: Zugriff auf „/proc/13429/fdinfo/4“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    root@FSC:~#


    @WastlJ


    hier der Output:



    Alles in allem scheint man auf dem richtigen Weg, wofür ich mich bedanken möchte. Ich war wohl an dem besagten Abend überhaupt nicht gut drauf, weil mein OMV Zeugs gemacht hat, was er eigentlich nicht sollte und ich überhaupt nicht wusste, was da passiert ist und ich mich nicht mehr einloggen konnte. Da will man diese OMV-Maschine mal seinen Freunden vorführen und stolz sein auf das Teil, und dann funktioniert die Kiste nicht richtig!


    Viele Grüße und Entschuldigung für meine unsachliche Kritik an den Entwicklern.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!