Samba stopped working

  • Everything was working just fine yesterday, I ran some updates, created an rsync and installed (but didn't configure any) plugins.


    I restarted the server.


    And now SSH is working and the WebUI are working, but I cannot access samba on my windows machine; my server is not displayed on the windows network discovery list anymore, and when I try to log in as my user I get "Access Denied" same if i try to log in as root (just tried to see if it was working at all...) I also created an account expressly to see if I could work around the issue by creating a new account, and if I try to log in with that I get this error:



    I tried restarting smb from the webui, it did not solve the issue. What do I do?

  • Weird error... Did you try restarting the windows box? Or try a different windows box?


    What is the output of: service samba status


    If it is running, I would:


    omv-mkconf samba
    service samba restart

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Code
    root@Vault1:~# service samba status
    nmbd is running.
    smbd is running.
    root@Vault1:~# omv-mkconf samba
    root@Vault1:~# service samba restart
    Stopping Samba daemons: nmbd smbd.
    Starting Samba daemons: nmbd smbd.


    Didn't change anything, I'm trying a restart now but honestly this was on a fresh boot so I'm 99.9% sure it won't do anything. I have not tried another windows nor linux host no I think I'll see what happens on my laptop though.

  • Yeah restarting did nothing, I tried logging into the new account first this time, and basically now I get the aforementioned error when I try to log into the original account instead.


    For the record, this is the error I'm usually getting (i.e. the one that is actually bothering me)



    I'm gonna check on my laptop now, but the one thing in particular I am noticing is that the domain name (NECEMBEL\Username) is the hostname of my Windows machine, is this normal?


    Update: Exact same issue on laptop, I also notice that if I try to go straight to SMB (not a specific share) I get a permission denied on both machines:


  • Samba is working. This is a permissions issue. Maybe permissions on the shared folder were changed. Try the reset permissions tab in the shared folder section.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • This did not fix things either, smbpasswd also ran without any errors.


    I wouldn't mind reconfiguring samba from scratch if that's what it takes, is there any way to completely reset it to the installation defaults?

  • Did you change anything on the settings tab? If not, deleting your shared folders basically resets to defaults.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • null the only thing I changed is the workgroup name, everything else is default in the webui, I haven't done any config from SSH either. I did recently restructure what I was sharing (i.e. I initially shared the entire drives, now I have it more compartmentalized) but the setup is the same as it was the last time it was working as far as my shared folders go.


    @subzero79 Hmm things are probably getting weird here: http://pastebin.com/e0jcZ9zD


    If you were just wondering about permissions though, then the permisisons for the shared directories I am trying to access are 2775/drwxrwsr-x


    Also again, one thing we shouldn't be forgetting is that Windows is not finding my samba share through network discovery (it used to when things worked) and that I am refused access to Samba itself, probably much rather than the individual shares (since after all it doesn't allow me to go into the source directory thing where I can see a list of all browseable shares) and I'll state again, I've double checked the firewall it's completely open to internal networks and samba is correctly detected from windows to the point where it asks for a user/password, it just always rejects further access.


    I just looked over smb.conf, I see nothing wrong in there, and the users I am trying to log in with are correctly listed for the shares I am trying to access.

  • @subzero79 I tried running it with the enclosing parentheses but I got the same results, I was running as root (You can see I was as root in the pastebin) this command is executing weirdly, but the share dir is 2775, the root dir (drive) is 2775 and /media where the drive is mounted (if that's relevant) is 0755.

  • Well, I can't stay locked away from my files longer than this, I haven't even finished working with them (gotta set up LUKS), so I guess I'll have to reinstall and start from scratch... but to be prepared to quickly fix this kind of problem if it ever crops up again, is there any way I could prepare a snapshot of a working OMV system to fallback to in case something goes wrong?

  • Not really. But if you install Debian you can use in the os disk lvm which has block level snapshots or btrfs with Fs snapshots. The latest one is not trivial to do it because the rootfs has to go on subvolume. But you'll find guides to that in the web


    Sounds like a major pain... Guess I'll just have to set things up and hope for the best then or just never update after I'm satisfied...


    Btw reinstalling fixed the problem, haven't done further testing, given the sudden nature of the problem I would be unsurprised if it happens again as I'm setting things up.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!