When will OMV3 be ready

  • OMV3 is currently using php 5.6, but can we upgrade it to php 7?

    Nope.


    Any issue?

    Lots of issues. First is that all php5-fpm configs and php files throughout OMV are hard-coded and/or file named for php5. Second issue is that the php5-pam library doesn't work with php7. Volker has a workaround using python but it didn't work on my system. Last, any update to the omv package would break everything again.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • So, OMV3 can't be built on php7 b/c it's built before php7 released?
    Meaning, we're unable to use php7 unless we break OMV3 system.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 2 times, last by tinh_x7 ().

  • So, OMV3 can't be built on php7 b/c it's built before php7 released?
    Meaning, we're unable to use php7 unless we break OMV3 system.

    I'm sure there will be an OMV 4 with PHP7-Support in the future... Give the flower some time to grow!

  • I'm fine with php5.
    I'm thinking Debian Jessie just released, so I thought we can benefit using php7 instead of php5 for web servers.
    Since there is no alternative solution yet except wait for OMV4 in the future.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • So, OMV3 can't be built on php7 b/c it's built before php7 released?
    Meaning, we're unable to use php7 unless we break OMV3 system.

    php7 is too much of a change for OMV 3. OMV 4 will definitely use it. I have modified it to work on php7. Quite a bit of work. Why do you need php7?


    I'm sure there will be an OMV 4 with PHP7-Support in the future... Give the flower some time to grow!

    Exactly.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • No, required libraries like PHP-PAM are not ported until now. Maybe the PHP5 module also works for V7, but I do not expect this. Without such important functionality it is not possible to go to PHP7.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!