Can Anyone help with script? OMV 2.2

  • Currently I have couchpotato and sabnzbd working well on my system. Headphones and sickbeard don't work but I want to sort out the two working first.
    The only thing remaining is a script that will move the completed files fro the download folder to the drive I have set aside specifically for media.
    This was just beyond my understanding: Transmission - Script to move completed downloads to directories, or how to create script? and what confused me was do I have to find the id all the time - one by one? Thing is I want to move them after they have finished so I want to write the script and run it as a scheduled job which I kind of assumed is a cron job in the backend.
    I saw this script on the internet but the developer did not put a description or guide. Just dropped it for the guy and I suppose both understood what they were doing but it is way too complicated for my level.

    If someone can help me customise it, I will be grateful.
    My sabnzbd folders are as follows:
    Temporary Download Folder:


    Completed Download Folder:


    Watched Folder:


    My permissions is 777 so pretty much anybody can write into it so there shouldn't be any permissions issues.
    Please can anybody help with using above script or sharing their script with instructions.
    The TV processing part was ok for me to customise but the movie section just threw me.
    Coding just floors me if it is too complex.
    Can anyone assist?

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

  • It would seem that there aren't many (if any) people trying what you are doing. I don't use any of those so I can't help. Try different things in a VM. Running a scheduled task (cron) isn't difficult to figure out.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks Guys.
    The reason I needed the script was because CP and Sabnzbd were not moving the files as they should. As I have got OMV in a state where it actually works without something breaking, I was reluctant to do anything that might injure that state of affairs. From various write ups, CP should move the folders - it does not.
    I am trying to install the Sonarr plugin and after updating Mono Testing repo and successfully saving it, I try to update the plugins and I get this error message:


    Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpg Ign file: Release Ign file: Translation-en Hit stoneburner Release.gpg Hit stoneburner-backports Release.gpg Hit virtualbox-wheezy-mirror Release.gpg Hit precise Release.gpg Ign squeeze Release.gpg Hit wheezy Release.gpg Hit wheezy/updates Release.gpg Hit wheezy Release.gpg Hit plex-wheezy-mirror Release.gpg Hit stoneburner Release.gpg Hit wheezy-backports Release.gpg Hit precise Release Ign squeeze Release Hit stoneburner Release Hit wheezy Release Hit wheezy-updates Release.gpg Ign stoneburner-miller Release.gpg Hit wheezy/updates Release Hit stoneburner-vb Release.gpg Hit wheezy-backports Release Hit precise/main amd64 Packages Hit wheezy/main amd64 Packages Hit wheezy Release Ign stoneburner-vpn Release.gpg Hit wheezy/updates/main Sources Hit stoneburner/main amd64 Packages Hit stoneburner-plex Release.gpg Hit wheezy-backports/main amd64 Packages/DiffIndex Hit wheezy-updates Release Hit wheezy/updates/contrib Sources Hit stoneburner-mono Release.gpg Hit virtualbox-wheezy-mirror Release Hit precise/main Translation-en Hit stoneburner/partner amd64 Packages Hit wheezy/main Sources Hit wheezy/updates/non-free Sources Hit plex-wheezy-mirror Release Hit stoneburner-mono-testing Release.gpg Hit wheezy-backports/contrib amd64 Packages/DiffIndex Hit wheezy/main amd64 Packages Hit wheezy/updates/main amd64 Packages Hit stoneburner-miller Release Hit stoneburner-backports Release Hit wheezy-backports/non-free amd64 Packages/DiffIndex Ign wheezy/main Translation-en Hit wheezy/main Translation-en Hit wheezy/updates/contrib amd64 Packages Hit stoneburner-vpn

    Even if I run apt-get update in CLI, I still don't get Sonarr. What am I doing wrong now?

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

  • Of course it does not help that the original issue I was contemplating posting was the automatic bridge my system was forming unasked:

    How can wlan0 and eth0 have the ip address?
    My router was told to do this:


    OMV - Wireless 00:87:40:7f:00:85 Reserved
    OMV-Eth0 b0:5a:da:87:d5:84 Reserved
    OMV-eth1 b0:5a:da:87:d5:85 Reserved

    So how it is managing to give two interfaces the same ip address I have no idea.
    The router is a Netgear Virgin Broadband router.

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

  • I will mark this thread as solved because I have managed to install Sonarr and it is a better package than Sickbeard.
    Immediately I installed it, it started downloading stuff whilst Sickbeard just sat there for weeks looking pretty but doing nothing.
    I will start another thread with the problem of having the same ip address for wlan0 and eth0

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!