Greyhole --> Red Dot after reboot

  • Hi,


    I am running the newest Greyhole plugin along with Snapraid and everytime I reboot my HP Gen8 Microserver a red dot appears for the service status. If I run

    Code
    wget http://omv-extras.org/debian/pool/main/o/openmediavault-greyhole/openmediavault-greyhole_2.1_all.deb
    dpkg -i openmediavault-greyhole_2.1_all.deb


    the red dot is gone but back after the next reboot. Not sure but greyhole seems to be working fine and there is nothing suspicious inside the log file (OMV WebGUI).


    Any ideas?


    Cheers
    Moritz

  • red dot is back after reboot and this is the output:


    Code
    mysql 2957 0.1 1.0 363324 42492 ? Sl 06:30 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/media/f55b4ae4-ae25-49db-ae75-f83565d07bdd/greyholeSQL/ --plugin-dir=/usr/lib/mysql/plugin --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
    root 3233 0.0 0.3 162124 13900 ? SN 06:30 0:00 /usr/bin/php -d open_basedir=/ /usr/bin/greyhole --daemon
    Moritz 8098 0.0 0.0 9904 916 pts/0 S+ 06:32 0:00 grep grey


    and the command "dpkg -l | grep greyhole" tells me

    Code
    ii greyhole 0.9.67-2 amd64 Drive pooling technology for Samba
    ii openmediavault-greyhole 2.1 all OpenMediaVault Greyhole (Storage pool server) plugin
  • Greyhole is running but the way the plugin determines if it is running is faulty. It looks for the phrase "is running" in the output of /etc/init.d/greyhole status to determine if greyhole is started. What is your output of: /etc/init.d/greyhole status

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Not sure why the service indicator is wrong then. Nothing you have to work about because the command you just executes is more accurate.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Uh no. That command just gives you a status. You don't need to do anything if you reboot. Greyhole is running just fine. The indicator in the web interface is wrong.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • sry, was talking about the command from my first post


    Code
    [font='Consolas, 'Courier New', monospace; font-size: 13px; line-height: 19.5px; white-space: pre-wrap']dpkg -i openmediavault-greyhole_2.1_all.deb[/font]


    but you're right, the indicator is wrong but Greyhole is running. There is no need to execute this command again after reboot


    Sorry for the confusion :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!