Communication Error

  • I have replaced the cpu of my HP Gen 8 G1610T server with a Xeon E31220 and increased the memory to 16GB. Then i purchased 4 x 4TB hard disks as I was beginning to run out of space on my Movies pool.
    I have successfully sorted out all the errors I was having before using this board and other linux help from the net. Now that I am ready to address my pool issue I can't get omv to list the hard disks so i can format them and include them in the pool.
    I am always getting a communication failure message which then results in a gateway timeout error message.
    i have read these boards and tried all the fixes I found such as : increasing timeout values to 180K, removing omv-emby (it was the precursor of the issues as all the apt-get update resulted in them re-installing emby).
    I have cleaned the cache using apt-clean, set iptables because I initially thought it was a network issue.
    The problem has escalated so such an extent that I can't access the hard disks section of omv which makes all the expenditure recently made a big whoop.
    Can anyone help analyse what I should do to resolve the situation?
    I have installed and got omv to the state I want it so I don't want to reinstall.
    There is just two things I noticed that I felt i should mention:
    1) Inspite of replacing the celeron with an Xeon, cpu still registers 100%
    2) There are 8 separate hard disks in 4 JBOD connected by 2 x SATA and 2 x USB3 and then 5 external NTFS hdd connected via USB2 through a powered hub
    Plan is to migrate all the ntfs hdd to the ext4 hdd but to do that I need access.
    So please can anyone assist?

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

  • I'd recommend you to start again, this time clean install. Avoid clogging your nas server with extra software at the host side. Use vm or docker (especially for emby or plex). Don't touch core components like php versions or ngnix.
    Rememeber to disconnect all data drives if you're going to reinstall.

  • I am just giving you a recommendation, since your system doesnt work at all apparently.
    If you want to know which process is eating your cpu use top command, disk IO using iotop. It could be the initialization of ext4 which can take up to 2 days in large filesystems

    You're using JBOD, why? you're getting into trouble for free, one disk goes south all data is lost, worst of it you're mixing interfaces (sata and USB) in that jbod array, use a pooling solutions mergerfs or mdadm raid array not mixing the interfaces in raid of course.

  • Sub - thanks . I know you were just recommending but it is frustrating because until i know what I am doing wrong, I will keep reinstalling. This will make the 10th time and I am still no nearer a solution.
    All the hard disks are connected to the server using JBOD. I then created three pools - genpool, pool and Movies_pool but i started running out of room in the movies pool and then a hard disk went and died on me so i had to replace it as it was part of a snapraid array. After buying the disk, I decided to migrate all the NTFS disks to ext4 so bought two more hard disks so I now have three new disks to format and include in the snapraid array and pool formation but I can't reach them to format.
    I wish omv can be reinstalled using the XML configuration file. It will make life so much easier.

    I have donated. have you?
    OMV 2.2 running on HP Gen 8 G1610T server, 16GB RAM + Xeon E3-1220

  • Do you really need a jbod on hw? Have you though about the risks in doing that?
    start with one or two disks in sata not usb. Move some data around see how it behaves. Then start adding more disks. also observe dmesg for the usb disks there might be a faulty one there, there are not very reliable for permanent storage.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!