Plex issue...

  • There is definitely something wrong with the 1.0.3 package on OMV 3.x. So, I pulled it until someone (not me) can figure out what is wrong.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello guys.


    I'm still having the main issue raised in this thread (files that require transcoding do not play). I've been through a few processes to get closer, and thought I'd share them here in case it helps someone.


    Currently running OMV 2.25 on a purpose built amd64 build, 4gb ram, amd kabini.
    I use plex on:
    plex.tv (through browser on desktop pc)
    Plex app on Amazon fire TV 4k
    Plexbmc plugin via kodi on Amazon fire TV 4k
    Plex app on android phone


    If I understand correctly, all of the above are set to transcode automatically, but I have set the Plexbmc plugin not to transcode unless it has to. Since this is my main way of using plex, I actually didn't know I had a problem until I tried watching transcoded media on my android phone. Currently, through all of the above methods of watching media through plex, nothing works except Plexbmc, presumably because it doesn't require transcoding.


    I read through this whole thread recently, and thought I'd check which plex plugin I have installed from OMV-Extras. It turns out I was using 1.0.12. I saw advice here to use 1.0.15 but I couldn't find it!. Even when refreshing or rechecking through the plugins button under System->Plugins, only 1.0.12 was showing as an option. What I had to do was go to the OMV-Extras.org button under System->OMV-Extras.org and disable the plex repository, save then apply. Then do the opposite to re-enable it. Once I had done so, plex plugin 1.0.15 was now available for download :thumbsup:


    Next was to get the plugin. Having read through this thread, it seems the plugin has been edited by Tekkb (thank you) in order to fix the issues with codecs being put in a different location among other things. I understood that the problem could therefore be solved by disabling the plugin, then re-enabling it. I have downloaded 1.0.15, disabled then re-enabled it, though so far I still have the same problem. The next thing I've read here is Tekkb's advice to do a purge:


    Code
    apt-get purge openmediavault-plexmediaserver
    apt-get purge plexmediaserver
    userdel plex
    rm -rf /etc/systemd/system/plexmediaserver.service.d

    I HAVEN'T done the above yet - happy to do so but just wanted to check it's the right thing to do.


    Two other outputs seems to be requested often:

    Code
    ls -la /opt
    total 32
    drwxrwxr-x 8 root users 4096 Aug 29 23:14 .
    drwxr-xr-x 24 root root 4096 Jul 9 18:00 ..
    drwxr-xr-x 6 root root 4096 Nov 24 2015 couchpotato
    drwxrwxr-x 6 couchpotato users 4096 Nov 24 2015 couchpotato_old
    drwxr-xr-x 3 plex plex 4096 Aug 29 23:14 plexcodecs
    drwxrwxr-x 14 sabnzbd users 4096 Jan 7 2015 SABnzbd
    drwxrwxr-x 9 sickbeard users 4096 Jan 15 2015 sickbeard
    drwxr-xr-x 2 sickbeard users 4096 Sep 16 2015 sickbeard2

    I presume you are looking to see whether plexcodecs are present under /opt, and there are as you can see. Also:

    Code
    dpkg -l | grep plex
    ii libmpc2:amd64 0.9-4 amd64 multiple precision complex floating-point library
    ii openmediavault-plexmediaserver 1.0.15 all OpenMediaVault Plex Media Server plugin
    ii plexmediaserver 1.0.3.2461-35f0caa-debian amd64 Plex Media Server for Linux

    I hope this helps in some way. I presume you are going to ask me to delete the plex library and directories (after saving them somewhere else), purge plex using the 4 lines previously mentioned, reinstall plex from scratch, stop the plex service, copy back my original folder over the new one while overwriting everything, then restart the plex service. Does this sound right?


    Thanks!

  • Thanks so much for this thread, I had 2 issues, couldn't find any updates which was fixed by updating the keys for OMV-extras and Plex not transcoding which this fixed.


    I was convinced a disk on my server was broken after a power cut but it was the noexec Codec issue.


    Thanks for fixing this!!

  • You are my heros !
    I tried so much, upgrading from OMV1 to OMV2, reinstall plex, moving data folder to another drive, but nothing helped: no videos were played
    The trick with the codecs folder did it.
    Now everthing runs perfect again.


    Thx !!!!

  • Hi all,


    I just installed OMV plex plugin, i got the repo from this thread : [GUIDE] Plex Media Server on Raspberry Pi 3


    Plex has been installed succesfully, i can acces plex media server dlna and from my samsung smart tv and i'm able to play movies.


    But from my browsers, its seems impossible to play anything, and i got this error message :





    Code
    Conversion failed. The transcoder crashed or failed to start up.


    I unistalled and then installed the plugin again (and again) but i'm still enable to play any medias from my browser.




    Can anyone Help please ?


    BTW :


    I'm using :


    RPi3
    OMV 3.0.51 (Erasmus)
    OMV-extras 3.4.6
    Plex repo : https://dev2day.de/pms/




    Can anyone help me to fix this please ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!