Plex issue...

  • The one in OMV-Extras section, nothing else. Wrong?


    If I disable that, I can't install the Plugin again, as the System can not find it.

    OMV 3.x - Plex Media Server - Auto Shutdown - LUKS Disk Encryption


    Intel Core i3 4130 @ 3,4 Ghz, 12GB RAM, 3x WD RED 3TB in RAID5 fully encrypted

  • This Plexediaserver package 1.0.0.2261-a17e99e is not starting if it is installed without the plugin. Going to have to look at this. Plex needs to start when it is first installed for the plugin to install correctly.

  • I might try dpkg -i with the plexserver and then manually restart it and then install the plexplugin?


    Does not work... getting the following error on web GUI:



    Failed to connect to socket: No such file or directory


    Fehler #0:
    exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:138
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Apt', 'update', NULL, Array, 3)
    #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #2 {main}


    Plugin install from command line with .deb package fails as well..


    I will go to bed now..maybe i will do a clean reinstall of OMV ...

    OMV 3.x - Plex Media Server - Auto Shutdown - LUKS Disk Encryption


    Intel Core i3 4130 @ 3,4 Ghz, 12GB RAM, 3x WD RED 3TB in RAID5 fully encrypted

  • It is trying to stat the library which is created on start of the plexmediaserver. If Plexmediaserver does not start the plugin cannot fully configure.


    Aaron and I worked on this before. I think we have to create our own package. I'm busy painting some tables. Stripped them of paint earlier. Sucky job. If I knew it was this big of a pain I would have tossed them and just bought new. Ugh!!!


    I will have to look at this later.

  • I just upgraded and I am unable to watch any anythign via the web browser. I can watch things via the client but when I try and watch in chrome or IE I get a message telling me "There was a problem playing this item."


    I noticed that at the end of the update there were many permissions being changed, could that have affected antying?

  • Did you follow these instructions??? Did you try clearing your browser cache??


    apt-get purge openmediavault-plexmediaserver
    apt-get purge plexmediaserver
    userdel plex
    rm -rf /etc/systemd/system/plexmediaserver.service.d


    FYI, I do all my testing with Chrome and it works fine for me. The permission changes in the update should not effect anything.

  • When I added libraries to this new version of Plex I got a warning message "Unable to load contents" but they did load. I don't know if there is some issue with this new plex package or maybe we need a small adjustment in changes with systemd. But it is working. I am able to add libraries. Just disregard that message. I did not have to add the plex user to the users group. It seems if you wait a bit the message goes away. Maybe just a delay in reading the directory.


    Also, the codecs seem to be downloaded on demand. So the first time you play a file it might have to download the requisite codec before it starts to play. This may cause a delay on first use of a given file type.

  • Hey @tekkb I just wanted to login and say thanks for making a script to move the codecs. I came across this a couple of days ago and gave up (seen something about locale settings and scared me when i ran dpkg-reconfigure locale) and came back and seen that it was a execution problem on mounted media drives. Glad I didn't proceed with the locale bs. Plex devs are probably going to leave it like that too? Learn something new everyday!

  • The plex devs have been doing weird things like that last 4 months. I think there has been some changes in the lineup. I see small issues here and there in the new plugins for OMV 3.x. There were a lot of changes because of systemd. They will improve, like always.

  • Question about the fix.


    Will it be required to use the OMV GUI to update plex or can it still be done from shell?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Either way...


    The only little issues I see are removal of the plugin if the person is not going to purge the plex package too. One thing that pisses me off is the plex package does not delete the plex user. There are a lot of old posts on the forum where this caused problems for users.


    I give you an example from the unit file. The unit file sets the default path for Support Directory.
    Unit file:
    /lib/systemd/system/plexmediaserver.service
    Environment="PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/var/lib/plexmediaserver/Library/Application Support"


    We are using an override to change this default path:
    /etc/systemd/system/plexmediaserver.service.d/db_folder.conf
    Environment="PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/media/ddc89061-f743-4229-923d-62dc93f16a6d/plexmediaserver/Library/Application Support"


    The problem here is when the plugin is removed this override file needs to be removed. But the path where the Support Directory resides will not be reflected in the unit file. After removal of the plugin the plex server will recreate needed folders/files are the default location at /var/lib/plexmediaserver and not know that you have already installed plex but moved the plexmediaserver directory to the data drive.


    Aaron and I argued about this a bit. I had originally altered the unit file directly using a sed command instead of using an override. The plex devs unit file was not correct at the time and did not even enable their /etc/default/plexmediaserver file.


    Anyway, some of these issues are due the devs at plex. We do what we can.

  • Plex devs still have not added this line to their unit file. It enables the /etc/default/plexmediaserver file.


    EnvironmentFile=/etc/default/plexmediaserver


    Aaron added it to our override to enable usage of the /etc/default/plexmediaserver file. We could throw a line in the end of the default file for the support directory path (Application Support), without editing their unit file, so plex would still function properly after removal of the plugin. But they don't have a proper unit file.

  • thanks for the post @tekkb, I updated today and went into freak out mode when plex stopped working. As mentioned disabling and re-enabling solved the problem.


    I almost feel like plex is making changes to just do it. I know my ps3 app keeps updating and losing functionality which is crazy to me. It also is super slow to navigate through the menus now.


    Im glad OMV has such an active community and issues like this are addressed super fast.


    On a side not is there any way to get the codec folder to populate with every possible codec without it having to download on demand?


    Thanks.

  • I think what they are doing is trying to have two main areas of their application. One area that is installed with their package and another area where items are downloaded post install when the server is running. This is being done without forethought concerning many people's systems that might have a data drive mounted noexec. Also, whoever is doing the systemd stuff too seems to be lacking some knowledge concerning unit files.


    On the codecs, if someone had a zip file of the Codecs folder from the Application Support Directory they could unzip it to /opt/plexcodecs. I don't think downloading on demand is a big issue though. Most of these files are not that big.

  • I rode from Atlanta to Savannah today and used the new 1.0 Plex server today and it was constantly dropping out and saying connection lost to server. SSH'd in and downgraded the plex server back to 9.16.6 and my problems went away. I am not going to upgrade again till things smooth out with plex.

  • I just did some testing with a remote client. The first time I connected and played a movie I was experiencing the same. Turned off secure connection on the client and then it never lost the connection. Turned back on secure connection only and now it is working fine. Weird... This was on my cell phone. I have really good upload speed for my server with Xfinity, 19 Mbps right now.

  • Press enable then go get a meal. It took quite a bit of time here to complete.


    For years I stayed away from the Plex plugin enable/disable button beacause it just appeared to fail, maybe an informative description next to this button "do not despair, enabling can take hours" would be useful?

  • I've done more testing of the new plex package, and new plugin, remotely with a Fire TV. Zero problems.... It is working as normal.


    @rebelmaveric19 I tested the crap out of it today. New package with new plugin working fine locally and remotely.

  • @rebelmaveric19 I was on my tablet last night doing more testing. Got repeated disconnects. My tablet was doing upgrades. Once the upgrades were done plex worked perfect again. I think anyone having repeated disconnects has poor upload at the server or download rate on the mobile device. Or maybe something like upgrades is effecting the download rate temporarily.


    I see no problems with the new plex package or new plugin other than minor issues with removal of the plugin mentioned already.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!