Web GUI Site Can't Be Reached Error

  • I am experimenting with the nginx plugin. I enabled the nginx plugin, and when I applied the changes I got an error. I subsequently got an error on every other webGUI item I tried to access. So I closed the browser tab (Google Chrome) and tried to go back into the WebGUI and got this error message:


    This site can’t be reached


    openmediavault refused to connect.


    Did you mean http://openmediavault.org/?
    Search Google for openmediavault


    ERR_CONNECTION_REFUSED


    I am positive I set the website port to 8080, since the webGUI is set to use port 80, but I can't go back in and verify now. Is there a way to disable nginx through SSH so I can recover the webGUI functionality?


    My network folders (SMB/CIFS) are still functional and I now see my site login when I hit port 8080 from my web browser, which is being served by nginx. Need to get the webGUI back though. Thanks in advance for any help!

  • Have you try omv-firstaid?


    Probably your Nginx port has conflict with OMV.


    If that doesn't work, then try this:


    Code
    1. sudo rm -f /etc/nginx/sites-enabled/openmediavault-nginx
    2. sudo service nginx restart
    3. Done.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • omv-firstaid works, but the only relevant menu I see is to change the WebGUI port, which is currently set to 80. If nginx is set to 8080, then there should be no conflict, right?


    I'm not very good at navigating around via SSH, so if you have any more info, I'd appreciate. Thanks.

  • omv-firstaid has other options too such as network interface: omv-firstaid Usage


    I often use second method if omv-firstaid doesn't work.
    Second method is more guarantee.
    It reset the Nginx settings.

    You can check the service/ports currently running: netstat -tunlp

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 2 times, last by tinh_x7 ().

  • I tried:

    Code
    1. sudo rm -f /etc/nginx/sites-enabled/openmediavault-nginx
    2. sudo service nginx restart
    3. Done.


    That worked! Thanks tinh_x7! :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!