Allow OMV to run in an iFrame?

  • I can't seem to find the code that blocks the option to run OpenMediaVault in an iFrame.


    At the moment I'm using Muximux/manage-this-node, so I have an overview of the different web services my NAS is running, but somehow OMV wont run inside the frame, as the rest of the things do.

  • It is an nginx setting. Look at this code

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It is an nginx setting. Look at this <a href="https://github.com/OpenMediaVault-Plugin-Developers/openmediavault-links/blob/master/usr/share/openmediavault/mkconf/links#L167" class="externalURL" rel="nofollow" target="_blank">code</a>


    Ah I see :) But isn't this only for when building omv?


    Doesn't configs in this folder:
    /etc/nginx/conf.d/
    get loaded by nginx?

  • That code disables the disables csp and xframe options. They are just features of nginx. Doesn't have anything to do with building OMV.


    The conf.d folder is for global configs. OMV doesn't use it by default.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!