Cannot connect to WebGUI

  • Hey,


    After doing some updates today on my 3.0.26 system, I cannot connect to the WebGUI anymore...
    After clicking on "Login", it loads for a while and then this error pops up:


    Code
    Fehler #0:
    exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:138
    Stack trace:
    #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}


    Can anyone help me with this please?

  • Hi,

    Please post the output. I assume you'll see an error message which is produced by an plugin you've installed.


    I assume you only need that error-line:

    Code
    PHP Fatal error:  require_once(): Failed opening required 'openmediavault/object                                                                                                                     .inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediav                                                                                                                     ault/engined/rpc/links.inc on line 21
  • The links plugin hasn't been ported for OMV 3.0.13+. Uninstall it. apt-get remove openmediavault-links

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The links plugin hasn't been ported for OMV 3.0.13+. Uninstall it. apt-get remove openmediavault-links


    Thanks a lot @ryecoaaron , I had to do this with the following packages:
    openmediavault-links,
    -med
    -subsonic
    -wol


    But now it works fine, thanks again :)



    EDIT: Wait, now it throws this error after logging in correctly:

    Code
    Fehler #0:
    exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:138
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 3)
    #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #2 {main}
  • I got through to the plugin-manager and uninstalled all plugins, now it's working.
    I'll check them all one by one now.
    Thanks for your help!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!