jdownloader doesn't start after update

  • I update to 3.0.32 (from 3.0.31) and jDownloader doesn't want to start. Here is the error:


    I tried to reboot a couple of time, but it doesn't work.
    Any ideas?

    OMV 4.1.9 64 - 4.17 backport kernel
    Intel J3160 - 8 GB Ram (2x4)

  • Solved: i tried to launch directly the command:


    /usr/bin/java -Djava.awt.headless=true -jar /opt/jdownloader/JDownloader.jar


    this is the output:


    Error: Unable to access jarfile /opt/jdownloader/JDownloader.jar


    then ls /opt/jdownloader there is not JDownloader.jar file but there is JDownloader.jar.backup.1
    I copied JDownloader.jar.backup.1 in JDownloader.jar and now it works, but i think this is not a very correct procedure

    OMV 4.1.9 64 - 4.17 backport kernel
    Intel J3160 - 8 GB Ram (2x4)

    Edited once, last by Max76 ().

  • I think it was solved, but it isn't.


    After a reboot the file jdownloader.jar is no more... =O

    OMV 4.1.9 64 - 4.17 backport kernel
    Intel J3160 - 8 GB Ram (2x4)

  • @Max76


    Did you solve the problem long term? I have encountered the same problem since a couple of month and jdownloader is practically not usable on my omv machine. Among reinstalling the plugin I tried a few things, but eventually jdownloader itself crashes and does not come up again. As a result only the backup jar file exists.


    I am also under the impression that self update does not work if the backup jar file is copied afterwards.


    OMV 3.0.47 with jdownloader plugin 3.2.1 on Debian with 4.7 backport kernel

    OMV 3.0.94


    Hardware:
    ASRock N3700-ITX
    1x4GB DDR3-1600 SO-DIMM
    2x4000GB WD Red and 2x4000GB WD Green in mdadm RAID5
    16 GB Mach Xtreme Technology Ultra MX-ES USB 3.0 as root
    Fractal Design Node 304 with PicoPSU

  • I have the same issue ... no way to restart it without uninstall / reinstall plugin ...



    Somebody can help on this ? Everytime, i need to setup again, and i have a lot of scripts running who use jdownloader plugin ...

  • I have the same
    The problem is that the jar file after update is changing the extension to .backup. A simple rename is solving the issue but I think that the problem is not from the plugin but the update mechanism of myJDownloader as it happens only when there is update.


    The myJDownloader shouldn't consider stable....

  • Same for me: jdownloader installed via OMV 3 plugin, starts updating itself for some minutes and after it hangs with JDownloader.jar.backup.1..
    I'm using a raspberry pi 2 with
    java version "1.8.0_65"
    Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
    Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)

  • For me the same on Banana Pro and Raspbian Linux.
    Is there no solution for this?


    Ps. Why is the thread solved?
    In my eyes is not solved in any way ... :thumbdown:

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

    Edited once, last by Aux ().

  • Guys. I don´t think there will be any updates in the future. Have you tried the Docker method? JD is also available as a Docker image. This is the way to go.


    However, if you prefer to use it as a plugin, you may need to fix something after every update.


    What does you JD output if you try to start it manually via CLI?

  • Why is the plugin not maintained if it's an available plugin?

    It was never ported to OMV 4.x and isn't maintained because the maintainer doesn't have time. He also thinks it is better to use a docker for this.

    omv 6.0.9-5 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!