General server and networking malfunction

  • As I can't diagnose the problem and it's too strange to me, I'll try to describe the situation.


    Yesterday my emby installation starrted to act strange. The emby app on my Tv seemed to log into the server but it wasn't loading all the contents. Only one or two here and there (I'm talking of video lists)
    So I went to my computer and tried to log into omv web gui, without success. Also I tried to log into ipmi web management but couldn't get into it.
    I realized that if I leave those pages loading, after some long time they load partially. In case of omv, it loads the background and title (no login) and ipmp loads an imcomplete login.


    network drives seemed accesible, but as I tried to open them windows stuck loading the content


    I also tried ssh and It connected, but as long I executed some command, as top, it became unresponsive and the ssh connection resets with a timeout.


    I tought then that the network port could be damaged and plugged the second one and configured for another IP. This worked. I could enter the OMV web gui and seemed fast and completely loaded. No IPMI though.
    So I executed omv-firstaid and configured the 1st interface with some other ip (ok) and then tried to configure the 2nd with the original ip. It failed when saving, but I could access the web gui on that ip.
    I saw anywhere that something failed with LO interface configuration (i'll try to reproduce again)
    The icons con the web gui where weird and the services where not working. Docker throws error opening it's page.... network interfaces page is empty...


    I thought of disk corruption on the SSD and got the smart values but all are ok. I executed shutdown -rF now so I could check the filesystem on boot, but showed several messages about being unable to unmount ZFS filesystems, failing stopping vbox and then stuck on "Deconfiguring network interfaces..."


    I pulled the cord and restarted it. While booting it showed the root fs check without problems.
    then




    Then stuck. ;(


    Well, it seems not to be stuck since I can insert an usb stick and it shows detection messages.

  • Started a recovery linux distribution and modified the network interfaces file to remove all IPv6 stuff and managed to continue booting.
    Then shows the following message: "chgrp: cannot access '/var/log/dmesg': no such file or directory"
    Followed by some other messages from umount, trying to unmount some /var/folders including /var/lib/openmediavault/rrd always showing "not mounted"


    Then stucks again for a quarter of an hour then resumes booting until the end.


    After that I can log into the web gui.
    Entering docker plugin shows the following error:


    Quote

    Error #0:exception 'OMVModuleDockerException' with message 'Error: "couldn't connect to host" - Code: 7' in /usr/share/omvdocker/Utils.php:63Stack trace:#0 /usr/share/omvdocker/Utils.php(180): OMVModuleDockerUtil::doApiCall('http://localhos...')#1 /usr/share/openmediavault/engined/rpc/docker.inc(354): OMVModuleDockerUtil::getContainers('42005')#2 [internal function]: OMVRpcServiceDocker->getContainers(Array, Array)#3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getContainers', Array, Array)#5 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'getContainers', Array, Array, 1)#6 {main}

    All other things work as expected, including VistualBox. Smart doesn't show any problem.
    Deactivating the flash plugin made the system boot up without any stop.


    Seems that something was messed during the docker update, that I have a failing ECC module :/ (ejemm) and that my first network port is also failing. ?(

  • ZFS Pools are not imported at boot. I have to manually import them each time.
    Virtualbox says: Object functionality is limited.
    Docker, after repairing it's configuration doesn't show any of my servers.


    Ahhh... I'm about to drop this thing and make a decent windows server machine.


    EDIT: It seems that all my remaining problems are from ZFS not mounting at boot.

  • The zfs plugin for OMV 3.x has just been ported. I recommend switching to OMV 3.x in a week or two.


    "decent windows server machine" - how is that possible :D

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!