Wordpress plugin installation problem

  • Dear all, have a strange problem I could not find reason / solution for some time already. Maybe I am missing something.


    OMV 2.2.6, kernel 3.2.0-4-686
    Installed OMV extras 2.13.2
    All updates
    Additionally installed and/or working well: FTP, Samba, OpenVPN, Plex, USBbackup, WEBdav


    Have no idea Pre-release updates and Community-maintained should be on or off for wordpress installation, right now they are off.


    Trying to switch on any of them right now gives an error:

    Code
    Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpg Ign file: Release Ign file: Translation-en Ign http://dh2k.omv-extras.org plex-wheezy-mirror Release.gpg Hit http://packages.omv-extras.org stoneburner Release.gpg Hit http://packages.openmediavault.org stoneburner Release.gpg Hit http://ppa.launchpad.net precise Release.gpg Hit .............
    etc, etc, etc




    What should I do with this?


    Following:
    Trying to install WordPress



    Trying to install mySQL:


    Was trying to install via command line, no success.


    Any help appreciated. NOT an expert in linux. Still know how to connect via command-line and execute primitive commands or replace /edit files, if not too complex :(

  • O.K. now I have no problems with enabling pre-release and community maintained updates.


    Still can't install Wordpress. Wordpress plugin installation asks for MySQL. MySQL installation says there is no MyWebSQL and php5-MySQL:


    Recommendations?

  • And what does it means?


    Code
    root@Server2:~# apt-cache policy mywebsql
    mywebsql:
    Installed: (none)
    Candidate: 3.6-omv4
    Version table:
    3.6-omv4 0
    995 http://packages.omv-extras.org/debian/ stoneburner/main i386 Packages
    root@Server2:~#
  • Code
    root@Server2:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@Server2:~#
  • No success so far.
    After omv-aptclean and apt-get -f install an update for omv-extras came up in web interface. I do not remember which version was before, but now omvextras is 2.13.4.


    Wordpress and MySQL still returns the same error messages in both: web interface and command line.



    Code
    The following packages have unmet dependencies:
    mywebsql : Depends: php5-pgsql but it is not going to be installed
    Depends: php5-sqlite but it is not going to be installed
    php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
    Conflicts: php5-mysqlnd but 5.4.45-0+deb7u2 is to be installed
    php5-mysqlnd : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
    Conflicts: php5-mysql but 5.4.45-0+deb7u2 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Made reboot of the server also after all the operations, didnt help.

  • That is your problem. You don't have enough Debian repos enabled. Try my repos


    As root:


    nano /etc/apt/sources.list


    Remove all lines and replace with:

    Code
    deb http://debian.mirrors.tds.net/debian/ wheezy main
    deb-src http://debian.mirrors.tds.net/debian/ wheezy main
    deb http://security.debian.org/ wheezy/updates main non-free
    deb-src http://security.debian.org/ wheezy/updates main non-free
    deb http://debian.mirrors.tds.net/debian/ wheezy-updates main non-free
    deb-src http://debian.mirrors.tds.net/debian/ wheezy-updates main non-free

    ctrl-o to save
    ctrl-x to exit


    omv-aptclean


    apt-get install openmediavault-mysql

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks a lot!!!!!


    Everything works as it should also from a web interface after aptclean.


    I remember I changed sources list long ago when original list (from installation ISO) was not working.


    You are doing awesome work, thanks once more!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!