Cannot get Plex to install on fresh install of 2.2.6

  • So, I just installed 2.2.6 on a Raspberry Pi 3 B+ and I cannot get the Plex Plugin to install. I'm not sure if this is because of the outage or not, but here is what I get from the ssh shell (i'm completely new to Linux so I appoligize in advance if I did this way wrong!).




    I attempted this with the beta version 3, same issue.


    Thanks for any help!

  • Repos are back up.

    Hi,


    Same here on OMV 2.2.6 @ RPi3. Is there something wrong on my side or the repos are still not 100%?


    Couchpotato and Transmission installed and have been running without any issue from the OMV-Extra repos via the OMV UI.


    What I tried:


    1. apt-get update (done without errors)
    2. OMV UI > OMV-Extras.org > Apt Clean


    3. apt-get -f instal

    Code
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    4. apt-cache policy plexmediaserve

    Code
    plexmediaserver:
    Installed: (none)
    Candidate: (none)
    Version table:

    I'm quite new to OMV and Unix so any help would be great.


    Thanks

  • yeah, its very weird, MiniDLNA installed fine, but the one for the ssh shell in the UI (cannot remember the name) I get the same error as Plex. One thing I noticed different with the RPi image and the regular install, is the OMV-Extras Testing Repo is enabled by default. And when I remove that, the ssh shell UI plug in is gone, so maybe that is an issue, or partly responsible? I don't know. I'm getting pretty frustrated though, and my lack of Linux knowledge is not helping lol.

  • and following this blog: http://www.htpcguides.com/inst…a-server-on-debian-linux/ I get this error:



    Code
    Fetched 819 B in 8s (98 B/s)
    W: GPG error: http://www.deb-multimedia.org wheezy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5C808C2B65558117
    W: Failed to fetch http://shell.ninthgate.se/packages/debian/dists/wheezy/Release Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)
    E: Some index files failed to download. They have been ignored, or old ones used instead.

    and I really think this is part of the issue because its not getting that armhf which is the ARM pkgs.

  • The shell.ninthgate.se repository holds only packages for x86/AMD64 hardware. They can not be installed on any ARM platform.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • No, it says that you can not install any x86/AMD64 packages on any ARM platform. That would include Plex Media Server.


    The OMV plugin for Plex Media Server is not the Plex Media Server software itself.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Plex media server isn't supported on the RPi.

    This is weird. Just before the OMV-Extras outage I was able to install Plex and it was running. I had to reimage the SD card because I didn't have RTC module and it'd got corrupted. Now that the OMV-Extras are back I cannot.


    What about this:

    It looks like the actual Plex server repository is missing from the package list hence OMV cannot install the Plex plugin.


    Sorry for my Debian lingo I hope I didn't say anything really stupid :/

  • Plex media server isn't supported on the RPi.

    so, weather or not this is supported or not is beyond me, however, I do have this working. This was like 10 hours of messing with this, but I'm like a level 1 Linux/bash user, so prolly should not have taken near that long lol.


    • Install OMV 3.0.24 to your MicroSD (I used Win32DiskImage).
    • Power your RaspberryPi up (I have the newest model 3 B+, I think)
    • Go to the web interface and go to OMV Extras and enable the PlexMediaServer Repo.
    • SSH to the rpi and run these commands (cobbled together from http://www.htpcguides.com/inst…rver-on-raspberry-pi-2/):

      • sudo locale-gen
      • locale -a
        • Make sure in the output here you have 'en_US.utf8' else go to the link it will explain how to add that to your locales and then regen.
      • ldd --version
        • if your version is 2.19 keep going else visit the link, there is a bunch of other crap you need to do.
      • sudo apt-get update && sudo apt-get install apt-transport-https binutils -y --force-yes
      • wget -O - https://dev2day.de/pms/dev2day-pms.gpg.key | sudo apt-key add -
      • main" | sudo tee /etc/apt/sources.list.d/pms.listjessieecho "deb https://dev2day.de/pms/
      • sudo apt-get update
      • sudo apt-get install plexmediaserver -y
      • (I'm not sure about this command this may not need to be run, it does a lot of stuff) sudo apt-get update && sudo apt-get upgrade -y
    • From the web interface go to plugins and enable the Plex Media Server plugin

    I'm just not working on setting everything else up, so I need to get my shares inplace to see what happens now, but I can see the Plex Plugin, and if I browse to the URL it is working.


    So I don't now what this says about whats broke, but I hope it helps the people that know what is going on to fix it.

  • Plex is supported on the RPi.


    Don't add any more repos. I just missed adding the package to the repo. I noted that when I said the repos were back up. Should be fine now.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • well, I decided to do a fresh install of 2.2.5. With all I did, I didn't want something down the road to screw me. Bummer I wasted so much time on this. I'm back up and running, but I'm having issues with DLNA from Plex on my bluray player. says the files are corrupt, but the play fine every where else. This was an issue when I had it on amd64 hardware too, must be a plex issue.

  • Hi @ryecoaaron - When I try and install 'openmediavault-plexmediaserver 3.6' I'm getting the issue described above on my fresh install of 3.0.41. Any ideas what I can do to add the necessary package?
    Thanks in advance

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!