probelm with php5-fpm

  • Hi guys,


    i have a problem with the php5-fpm deamon.


    i installed nextcloud via the nginx addon with this How-To.


    After an omv-update and an reboot, i have a problem with the omv gui and the nextcloud-site.


    i get an nginx error : 502 Bad Gateway


    i found some errors in the logfile:


    root@nas-pi:~# systemctl status -l php5-fpm
    ● php5-fpm.service - The PHP FastCGI Process Manager
    Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
    Active: failed (Result: exit-code) since Sat 2016-09-17 14:06:43 CEST; 22min ago
    Process: 2287 ExecStart=/usr/sbin/php5-fpm --nodaemonize --fpm-config /etc/php5/fpm/php-fpm.conf (code=exited, status=78)
    Process: 2280 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
    Main PID: 2287 (code=exited, status=78)



    Sep 17 14:06:43 nas-pi php5-fpm[2287]: [17-Sep-2016 14:06:43] ERROR: [/etc/php5/fpm/pool.d/1d745a75-7efd-467f-b4b2-c9f3d52a0fc2.conf:26] value is NULL for a ZEND_INI_PARSER_ENTRY
    Sep 17 14:06:43 nas-pi php5-fpm[2287]: [17-Sep-2016 14:06:43] ERROR: Unable to include /etc/php5/fpm/pool.d/1d745a75-7efd-467f-b4b2-c9f3d52a0fc2.conf from /etc/php5/fpm/php-fpm.conf at line 26
    Sep 17 14:06:43 nas-pi php5-fpm[2287]: [17-Sep-2016 14:06:43] ERROR: failed to load configuration file '/etc/php5/fpm/php-fpm.conf'
    Sep 17 14:06:43 nas-pi php5-fpm[2287]: [17-Sep-2016 14:06:43] ERROR: FPM initialization failed
    Sep 17 14:06:43 nas-pi systemd[1]: php5-fpm.service: main process exited, code=exited, status=78/n/a
    Sep 17 14:06:43 nas-pi systemd[1]: Failed to start The PHP FastCGI Process Manager.
    Sep 17 14:06:43 nas-pi systemd[1]: Unit php5-fpm.service entered failed state.





    root@nas-pi:~# cat /etc/php5/fpm/pool.d/1d745a75-7efd-467f-b4b2-c9f3d52a0fc2.conf
    [1d745a75-7efd-467f-b4b2-c9f3d52a0fc2]
    listen = /var/run/fpm-1d745a75-7efd-467f-b4b2-c9f3d52a0fc2.sock
    listen.owner = www-data
    listen.group = www-data
    listen.mode = 0600



    user = www-data
    group = www-data



    ; Process manager
    pm = dynamic
    pm.max_children = 5
    pm.start_servers = 2
    pm.min_spare_servers = 1
    pm.max_spare_servers = 3
    pm.max_requests = 0



    ; php.ini
    php_flag[display_errors] = Off
    php_flag[html_errors] = On
    php_value[max_execution_time] = 30
    php_value[memory_limit] = 128M
    php_value[post_max_size] = 8M
    php_value[upload_max_filesize] = 2M
    ; extra options
    client_max_body_size 10G; # set max upload size
    fastcgi_buffers 64 4K;



    rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
    rewrite ^/carddav(.*)$ /remote.php/carddav$1 redirect;
    rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;



    index index.php;
    error_page 403 /core/templates/403.php;
    error_page 404 /core/templates/404.php;



    location = /robots.txt {
    allow all;
    log_not_found off;
    access_log off;
    }



    location ~ ^/(data|config|\.ht|db_structure\.xml|README) {
    deny all;
    }



    location / {
    # The following 2 rules are only needed with webfinger
    rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
    rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;



    rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
    rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;



    rewrite ^(/core/doc/[^\/]+/)$ $1/index.html;



    try_files $uri $uri/ index.php;
    }



    location ~ ^(.+?\.php)(/.*)?$ {
    try_files $1 = 404;



    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$1;
    fastcgi_param PATH_INFO $2;
    fastcgi_param HTTPS on;
    fastcgi_pass $socket;
    }



    # Optional: set long EXPIRES header on static assets
    location ~* ^.+\.(jpg|jpeg|gif|bmp|ico|png|css|js|swf)$ {
    expires 30d;
    # Optional: Don't log access to assets
    access_log off;
    }





    Do you have some ideas?


    Best Regards!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!