error message: Failed to execute XPath query

  • I can't get my list of jobs and can't create new jobs all i get is error message:


    Failed to execute XPath query


    Error #0:exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//system/shares/sharedfolder[uuid='57d38c39-2013-41ac-9333-82db4f28c704']'.' in /usr/share/php/openmediavault/config/database.inc:78Stack trace:#0 /usr/share/openmediavault/engined/rpc/rsync.inc(77): OMV\Config\Database->get('conf.system.sha...', '57d38c39-2013-4...')#1 [internal function]: OMVRpcServiceRsync->getList(Array, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)#4 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Rsync', 'getList', Array, Array, 1)#5 {main}


    Is there a way to reset RSync service.
    thanks.

  • to answer your question, you have to manually modify /etc/openmediavault/config.xml. Search for rsync and delete everything between <jobs> and </jobs>.

    After successfully using Rsync once, and then deleting the shares I had used, I have the same problem.


    Is there a way to do this from the command line? Step by step? Or another way to edit and save the config.xml file other than shellinabox? I have installed shellinabox, but whenever I try to run the web client is won't get past the login password, so I can't use it.


    Updated 3 hours later-
    Woo Hoo! I ran nano /etc/openmediavault/config.xml and followed exactly what you said, votdev. Did the trick! Rsync now runs without the Xpath error.


    Thanks a bunch!

  • I had the same problem, after messing around some directories manually rsnyc threw up some error messages. Editing the xml fixed it!

    Usul 5.4.5-1


    on


    Mobo: Asus H87I-Plus (C2) Socket 1150
    RAM: 4GB (1x 4096MB) Kingston ValueRAM DDR3-1600 DIMM CL11 Single
    CPU: Intel Pentium G3220 2x 3.00GHz So.1150 BOX
    PS: 300 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Bronze
    OS: 64GB SanDisk Solid State Disk (SDSSDP-064G-G25)
    Data: 2x 4000GB WD Red WD40EFRX
    Case: Chenbro SR30169 mini ITX (4 bay) - but removed that crappy backplane :)

  • to answer your question, you have to manually modify /etc/openmediavault/config.xml. Search for rsync and delete everything between <jobs> and </jobs>.

    I don't know how else to say this but I could kiss you right now. I just ran into this issue and for once I found a very simple (to me) and easy fix that got me RIGHT through to what I needed to do. Very awesome sir.

    OMV 3.0.76


    Asus Z97, Intel i7-4770
    16gb Ram
    Corsair 550w PSU
    Fractal Design Mini Black MATX Case (5 Fans)
    4x WD 6TB Red (Raid 6) Main Storage
    2x WL 3TB (Raid 1) Secondary Storage / Future Cloud
    30gb SSD (OS)
    Plex Media Server Lifetime Pass member
    Linux n00b

  • Hello,


    I have this problem when visiting the Rsnapshot page to add a job.



    Code
    Fout #0:
    OMV\Config\DatabaseException: Failed to execute XPath query '//system/shares/sharedfolder[uuid='5ae0e2f5-8189-4682-828d-37a60d8a3ee2']'. in /usr/share/php/openmediavault/config/database.inc:78
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/rsnapshot.inc(73): OMV\Config\Database->get('conf.system.sha...', '5ae0e2f5-8189-4...')
    #1 [internal function]: OMVRpcServiceRsnapshot->getList(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
    #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('RSnapshot', 'getList', Array, Array, 1)
    #5 {main}

    Applying your fix doesnt work for me. Any idea?


    Thanks


    Edit: Fixed by doing the same in the Rsnapshot section: remove jobs. Thank you.

  • I still don't have a clue how to fix it...



    I've installed the newest version of OMV on muy Pi 3... I don't know how to remove that annoying error. I don't even know where I could find the cli/cmd. I ran the command "nano /etc/openmediavault/config.xml" over tasks then set it as a daily task and manually run it immediatly. Didnt have any sense because it gave me another error.


    Who can help me with this problem because I can't solve it myself neither Google helped me...


    Thanks

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!