omv-extras errors

  • I haven't seen a thread that addresses this problem, so here is a new thread.


    I have just completed installation of OMV on a USB thumb drive and have been trying to download/install omv-extras so I can get to the flashmemory plug-in, as well as install upgrades through the update manager. I have tried doing this multiple times, and I keep getting all manner of errors in both instances which causes the installs and upgrades to never complete.


    At a minimum, is there any way to get just the flashmemory plugin so I can be assured that my installation remains stable?


    Then, is there any help out there as to why these two features (Update Manager & Plugin) keep failing to install?

  • I'm attempting to process the Update Manager. So while waiting for that, here are the error messages I'm getting from the attempt from root:
    "libc-bin is already the newest version.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    libc6 : Depends: libc-bin (= 2.13-38+deb7u8) but 2.13-38+deb7u11 is to be installed
    openmediavault-omvextrasorg : Depends: openmediavault (>= 2.1.11) but 2.1 is to be installed
    Depends: apt-transport-https but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)."


    So I ran apt-get -f install and it comes back with:
    "Reading package lists... Error!
    E: Problem renaming the file /var/cache/apt/pkgcache.bin.w9CZJp to /var/cache/apt/pkgcache.bin - rename (2: No such file or directory)
    W: You may want to run apt-get update to correct these problems"


    So, while typing the above, the WebGUI finished Installing updates and near the end of the log I see "dpkg: error processing libc-bin (--configure): Package is in a very bad inconsistent state - you should reinstall it before attempting configuration.
    Errors were encountered while processing:
    libc-bin
    Creating index of upgradeable packages ...
    Creating index of OpenMediaVault plugins ...
    E: Sub-process /usr/bin/dpkg returned an error code (1)"

  • Tried, again, to install OMV-Extras from the command line. Here is how it went:
    "dpkg -i openmediavault-omvextrasorg_latest_all.deb
    (Reading database ... 28917 files and directories currently installed.)
    Preparing to replace openmediavault-omvextrasorg 2.13.4 (using openmediavault-omvextrasorg_latest_all.deb) ...
    Unpacking replacement openmediavault-omvextrasorg ...
    dpkg: dependency problems prevent configuration of openmediavault-omvextrasorg: openmediavault-omvextrasorg depends on openmediavault (>=2.1.11); however: Version of openmediavault on system is 2.1
    openmediavault-omvextrasorg depends on apt-transport-https; however: Package apt-transport-https is not installed.


    dpkg: error processing openmediavault-omvextrasorg (--install): dependency problems - leaving unconfigured
    Processing triggers for openmediavault ...
    Restarting engine daemon ...
    Errors were encountered while processing: openmediavault-omvextrasorg"


    After running apt-get -f install, the root keeps telling me to reinstall libc-bin because of very bad inconsistent state - how the heck do you do that?????


    What a mess ...


    So, is there a way to install flashmemory plugin independently?

  • So, is there a way to install flashmemory plugin independently?

    This is avoiding the problem and won't work anyway for the same reason omv-extras won't install. Your system is in a bad state. Try


    apt-get -f install
    dpkg --configure -a


    If that doesn't work, post the output of:
    dpkg -l | grep -v ^ii

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get -f install
    dpkg --configure -a


    If that doesn't work, post the output of:
    dpkg -l | grep -v ^ii

    I ran the above. Here is what it said:
    "dpkg: error processing openmediavault-omvextrasorg (--configure): dependency problems - leaving unconfigured
    Errors were encountered while processing:
    libc-bin
    openmediavault-omvextrasorg"

    If that doesn't work, post the output of:
    dpkg -l | grep -v ^ii

    "Desired=Uknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++=============================================================================================================================================================================
    iUR libc-bin 2.13-38+deb7u11 amd64
    Embedded GNU C Library: Binaries
    iU openmediavault-omvextrasorg 2.13.4 all
    OMV-Extras.org Package Repositories for OpenMediaVault

  • In many of the error message strings from the command screens, it indicates that my version of OMV is 2.1 whereas the installs are looking for version 2.1.11 or greater. I don't know what to do with this.


    Maybe I'm looking at one more re-install of the whole system? I saw that in the updates, there was a newer version 2.2 - but couldn't seem to load that one either because of this libc-bin problem.

  • While I would reinstall, if you can get libc installed and update OMV, it might be fine.


    apt-get install libc-bin=2.13-38+deb7u11
    apt-get update
    apt-get install openmediavault

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get install libc-bin=2.13-38+deb7u11
    apt-get update
    apt-get install openmediavault

    libc-bin 2.13-38+deb7u11 is the culprit. Every time we try something, including your suggestion above, I get a Depends error where libc6 depends on libc-bin 2.13-38+deb7u8 and the deb7u11 version to be installed is killing it.


    You are absolutely right, if we could get past libc-bin, I think it would straighten out. But how to get that to happen?

  • If I haven't heard any suggestions within another hour or so, I think I'll throw in the towel and do a complete reinstall.


    I hate it when a problem occurs that can't be explained or resolved in someway. This libc-bin issue seems to be in a closed loop, and no way to get out of it. (Kind of like Clark Griswald getting stuck in the Lambeth Bridge Roundabout in National Lampoon's European Vacation.) Something is amiss.


    Maybe if I could get my hands on libc-bin 2.13-38+deb7u8 and installed that, we could get the dependencies through the install and then continue with the upgrade.


    I have Googled libc 2.13-38+deb7u9 and see that on many Linux installs, whether Kalix, Debian, Unbuntu, or others, this is a common problem. Most of those links suggest a complete reinstall.


    So If I haven't heard about any other ideas and proceed with a reinstall, are there any pointers you might make regarding exactly how to proceed? Such as, only install from the command line; don't attempt any plugins or general updates until updating Stone Burner to version 2.2.10; or some other suggestions?


    What do you think?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!