NFS for n00bs, I read the NFS pin!

  • Hi,

    Forgive me for my ignorance. I read over the NFS pinned page and I think I found the problem but would like to run it by you experts. I recently acquired a server and have been messing around with EXSi and virtual machines. I created to me what was a very complicated setup for a simple task but it failed.

    I created:

    VM 1 = OMV
    VM2 = CentOS7 with PlexMS
    VM 3 = ubuntu server with sabnzbd
    VM 4 = CentOS with Sonarr

    I have the NFS share:


    The VM2 can read and write to the /Plex/TV nfs that is mounted as /mount/nfs/TV
    VM3 downloads to /sabnzbd/incomplete and /sabnzbd/complete fine mounted on /mount/nfs/sabnzbd/incomplete and /mount/nfs/sabnzbd/complete
    VM4 has mounts /sabnzbd/complete mounted to /mount/nfs/complete and /plex/tv mounted to /mount/nfs/tv

    I think this is where my problem starts:

    I have a category in sabnzbd which creates the folder in complete/tv to move completed sonarr triggered downloads

    Sonarr shows in the log that it can't access the downloaded files in /complete/tv to process and move to /Plex/TV

    I started creating users on OMV to match the users on the various VMs, but it looks like I might have mistakenly started to do this since NFS is not based on user/password permissions.

    Is my hypothesis correct in that I just need to make the different user on each of the VMs that is running is set to group with GID=100?

    I know i can do SMB here, but since I am trying to run an all linux environment and want to stay native, I want to give NFS a go.

    Thanks for your time,


  • Why do you have all these VMs?

    I run PlexMS, sabnzbd, and Sonarr on OMV directly.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • I have figured this out. I needed to add a "domain" to all the VM's so that they are on the same and made sure the usernames that I used for the VM's were also in the OMV user's list. After that, the NFS shares were visible and worked perfectly.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!