Virtualbox- shared folder is read-only in guest

  • Hello :) ,


    I've been pulling my hair out for a few days.


    The (Debian) guest I have set up in Virtualbox can only read from a shared folder with the host. It cannot write, rm, etc to the shared folder.


    I've checked and double checked that the folder is not marked "read-only". I've tried move the shared folder to another data drive. I've tried writing to the shared folder as root in the guest. I've added my user account to the vboxsf group. I always get errors similar to the following:


    touch: cannot touch ‘hi.txt’: Protocol error


    rm: cannot remove ‘hi.txt’: Operation not permitted


    Although I can list and read files in the folder.


    I even tried reinstalling the plugin and building a new guest. Same issue.


    My permissions for the folder are as follows:


    In host: drwxr-xr-x 2 root users 4096 Nov 7 15:12 shared
    In guest: drwxrwx--- 2 root vboxsf 4096 Nov 7 13:07 sf_shared


    Anybody able to point me in the right direction for fixing this?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!