Using sym links in samba

  • This will help if you are using sym links.


    follow symlinks = yes
    wide links = yes
    unix extensions = no


    Default install has wide no and unix yes.Once I changed /etc/samba/smb.conf settings to the above sym links worked great.




    Side notes:I could share one folder with a many folders from all over the server. really nice to handle a big sharing sever for media and software for family.I just hit 10TB of Plex Media and 8TB of ISO's. Iso i need to clean up i think .. lol.But plex I moved to a docker container so I would teach myself docker to help me at work.It is doing really well there, Surprised myself. I thought it would suck. But it acts just like it did any other place I have had it.Docker is something to look at and its kinda fun to learn. And $$$ if you work in the industry.


  • Hi votdev,


    Adding next lines, at end of /etc/default/openmediavault file?


    Code
    OMV_SAMBA_SHARE_FOLLOWSYMLINKS="yes"
    OMV_SAMBA_WIDELINKS="yes"
    OMV_SAMBA_UNIXEXTENSIONS="no"

    Needs reboot server?




    Thanks

  • Does this still work with omv 4.1.6 .. I made the changes , omv-mkconf ..and systemctl reload smbd.service


    but still not visible from windows 7 .


    I tried also to put these options it web SMB/CIFS configuration .. and it doesn't work !!


    SMB/CIFS extra options:
    unix extensions = no


    Share extra options:
    follow symlinks = yeswide links = yes


    Something is not working as expected, but what ?

    Edited once, last by Rizos39: Additional information: I checked the /etc/samba/smb.conf and there are these change: root@omv4vm:~# diff smb-before.txt smb-after.txt 1c1 < root@omv4vm:~# cat /etc/samba/smb.conf > smb-before.txt --- > root@omv4vm:~# cat /etc/samba/smb.conf > smb-after.txt 26,27c26,27 < unix extensions = yes < wide links = no --- > unix extensions = no > wide links = yes root@omv4vm:~# ().

  • Additional info



    I checked the /etc/samba/smb.conf and there are these change:


    root@omv4vm:~# diff smb-before.txt smb-after.txt
    1c1
    < root@omv4vm:~# cat /etc/samba/smb.conf > smb-before.txt
    ---
    > root@omv4vm:~# cat /etc/samba/smb.conf > smb-after.txt
    26,27c26,27
    < unix extensions = yes
    < wide links = no
    ---
    > unix extensions = no
    > wide links = yes
    root@omv4vm:~#

  • I answer to myself, in the hope it is helpfull for others :-)


    The problem is that the destination of the symbolic link is inside of


    root@omv4vm:~# ls -lad /root
    drwx------ 5 root root 4096 Aug 13 20:46 /root
    root@omv4vm:~#


    ARgg ........ why that doesnt say no privileges ? instead it does not appear at all !!!!!!!!!!!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!