Error: "Failed to read file '/tmp/bgstatusfs2WVj' (size=0)."

  • Is it possible that this is a race condition ?

    Hard to say. Maybe Volker's latest commit will make it easier to figure out. I don't see it on my VMs very often any more.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I also receive this error message every time i try to work with the web-gui.
    For example creating a new schedule or simple try to update packages.


    Running on 4.1.1-1
    Kernel 4.14.0-0.bpo.3


    Funny fact:
    I've a backup server running same version of omv and kernel. On this machin the web-gui is working like a charm.
    The main server was a fresh install of omv4 and the backup-server was an update from omv3 to omv4. That is the only software difference.

    omv 4.1.9 arrakis | Kernel 4.17.0-0.bpo.1 | 64bit
    Parallel installed: tvheadend 4.3

    Edited once, last by sash ().

  • Short update from my side.


    At the moment everything is working as expected.
    Unfortunately i can't tell you exactly what I've done to make everything working.


    But what i can tell is that i run the command

    Code
    sudo rm /tmp/*

    and clear up the tmp folder.
    At the execution time of this command i wan't connected to the webgui. Don't exactly know if this does the trick.
    Also i did a reboot (was more a mistake and not planed).


    After that i went to the webgui and tried several times the manual update button with success.
    Also i executed some planed schedules by hand and all of them are working. No matter executing as root or not.


    Cheers

  • Running latest build, 4.1.4-1 and having the same problem, can't access my disks/file systems tab in my webGUI.


    Only commonality I see between some of us here are AMD CPUs. It also seems to happen to me when the loading bar on the webGUI is involved.

  • Hello everybody,
    I have the same issue on a clear installation of 4.1.3 on a system with AMD Fusion and usb key.
    I didn't find the trigger that caused Failed to read file '/tmp/bgstatusFJIZLF' (size=0) but probably it appeared during File System setup but on the first time i was probably setting up network (I tried 2 installation).
    After the error it's impossible to do anything on web gui.
    I had tried to perform omv-aptclean but the respond was bash command not find, I also tried to rm /var/lib/openmediavault/dirtymodules.json but didn't resolve the issue.

  • Well, I have a similar issue (don't want to hi-jack the thread but seems related so no new topic)


    After upgrade to Arrakis I keep getting upgrade errors in the webgui and through SSH. The upgradeable packagers are downloaded and installed but only if I use apt in SSH (webgui refuses to upgrade).


    These are the errors I get:


    Webgui:


    SSH:

    As said the upgrade works but the error is a bit annoying and confusing. I tried removing the files but that didn't help. The /tmp/ folder has no other files and just a few sub folders.


    Anyone any clue?


    Greetz,


    Sjonnie

    Server 1: Tranquil SQA-5H modded - OMV Arrakis :thumbsup:
    Server 2: Homebrew server - Ubuntu 16.04 with webmin
    Server 3: Synology DS215+
    Server 4: Synology DS211
    ...and some client devices to justify the servers 8o

  • Some news.
    I have done a new fresh installation, every time the error "Failed to read file '/tmp/xxxxxxxxxxxxxx' (size=0)." appeared I perform rm /var/lib/openmediavault/dirtymodules.json and so it's possible to complete the operations. Important is to not cancel the file between apply the change and save that, in this case is enough to close the error windows, and after the completion of saving perform rm command.
    I noticed that the error appear also on random time basis in other words I left my web GUI open for about 1 hour and when I controlled the screen I found many windows with the error.

  • Hello!



    I´m running into this error message, too.


    Clean install of OMV 4.1.3-1 from USB-Stick (official image) to a completely wiped SSD.
    System is an ASRock J3455-ITX with 8Gb Ram.


    I´m getting numerous of these error messages when writing a file system to my new WD Red 4Tb (I chose ext4).


    Failed to read file '/tmp/bgstatusybdepR' (size=0).
    Failed to read file '/tmp/bgstatustG0rdl' (size=0).
    Failed to read file '/tmp/bgstatusIKjyzU' (size=0).
    ...
    (Just to qoute a few).


    Details:


    Fehler #0:
    OMV\Exception: Failed to read file '/tmp/bgstatuscWtT3y' (size=0). in /usr/share/php/openmediavault/json/file.inc:199
    Stack trace:
    #0 /usr/share/php/openmediavault/json/file.inc(214): OMV\Json\File->getContents()
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(314): OMV\Json\File->read()
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(544): OMV\Rpc\ServiceAbstract->finalizeBgProcStatus('/tmp/bgstatuscW...', '', Object(OMV\Exception))
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(440): OMV\Rpc\ServiceAbstract->callMethodBg('getList', Array, Array)
    #5 [internal function]: OMVRpcServiceFileSystemMgmt->getListBg(Array, Array)
    #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getListBg', Array, Array)
    #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getListBg', Array, Array, 1)
    #9 {main}



    Plus also got "Invalid RPC response. Please check the syslog for more information."



    WebGUI is working though and OMV seems to complete the task.



    Are these errormessages safe to ignore?



    Updating via the WebGUI to 4.1.4-1 didn´t change this behaviour.


    But.. I got some RPC Errors during the upgrade process here as well.


    So... not sure what to think. Could maybe OMV 3 be a better option for the time being?



    Many thanks in advance.

  • It is a php bug. We haven't found a workaround.

    don't mean to be rude, but i think more than 6 months after the issue has been first reported a more detailed explanation would be appropriate. like "we have reported that but to the php team and they will include a fix in the next release" or "due to this issue we have decided to completely rewrite omv's frontend to a different framework. it will take maybe a year to be completed, but the results will be awesome" or anything inbetween. hm?

    HP Proliant Microserver Gen8, E3-1265Lv2, 16 GB ECC RAM, 3x WD RED 3TB + 1x WD RED 4TB + Crucial MX300 525 GB SSD.

    Powered by Proxmox VE


  • Failed to read file '/tmp/bgstatusxxx' (size=0).


    So is this basically a bug with the webgui/frontend and safe to ignore?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!