Raid 0 grow

  • Hi guys, I would like how to add more disks to an openmediavault running two 2TB disks in raid 0. I have more two 2TB disks and I would like to add those disks but without loose my data that had previously recorded in the 2 existent disks.
    Sorry about the bad english, I'm from Brazil.
    Hugs to all.

  • Hi, well, the grow button is grey and it's not possible to do through the web interface, in the other hand, I tried to do using mdadm command line, no success...
    Other problem is that the amount of data recorded in the OMV is 2.8 TB and I have nothing with this size to move the data away and reconstruct the raid again with the new disks.
    I'm trying to find a way to grow the Raid 0, but seems that could be impossible...
    I'm stuck on this situation, any help will be welcome.
    Anyway, thanks for your interest.

    p.s.: Could you give me the sintax of mdadm command to try to grow, maybe I did something wrong ! I followed instructions on the mdadm man page !
    This what I have when I tried to do the grow:

    root@openmediavault:~# mdadm --add /dev/md127 /dev/sde
    mdadm: add new device failed for /dev/sde as 2: Invalid argument

  • wow, did I read well? You are trying to expand a raid 0 but don't have any backup. It seems you like to live dangerously: one drive dies and so does the whole array... The odd of this happening with 3 drives being higher than with 2 drives.

    I don't know if mdadm allows to grow a raid 0 (I thought you wanted to grow a 2 drives raid 1 array to a 3 drives raid 5 array, which is possible with mdadm), but did you try the following command:
    mdadm --grow /dev/md127 --raid-devices=3 --add /dev/sde

    By the way, try this first in a VM as I won't be held responsible if it crashes your array. You've been warned.

  • Hi Pollux,

    The entire OMV is running on a VM... I'm just testing the possibility to grow the raid 0. I have backup of all data, this is just a preparation for an action to be taken in a real machine that is running since the last year and now need to be grow.
    Anyway, thanks for the tip, I tested and this happened:

    root@openmediavault:~# mdadm --grow /dev/md127 --raid-devices=3 --add /dev/sde
    mdadm: --add cannot be used with other geometry changes in --grow mode

    That's it. But no problem, if it's not possible to grow a raid 0 we will dismantle the raid and use raid 5 when we add the two new more disks. I'm trying to make my life easy hehehe !

  • Hummmmm, I see... Well, if it is not possible then I will go for the last option, dismantle everything and rebuild using Raid 5.
    Thanks for the help guys, I appreciate that !

    Hugs to all

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!