OpenMediaVault on the ETrayz (Oxnas810 device)

  • Hi,


    First of all thank you for your great work !
    I'm trying to install openmediavault on eTrayz (Oxnas810 device), which runs debian lenny and get following package errors:
    The following packages have unmet dependencies:
    openmediavault: Depends: php5-pam but it is not going to be installed
    Depends: samba-common-bin but it is not installable
    Depends: acpid but it is not installable
    Depends: gdisk but it is not going to be installed
    Depends: xmlstarlet (>= 1.3.1) but 1.0.1-2 is to be installed


    I cannot upgrade eTrayz to squeeze as the kernel source is only 2.6.24.4.


    How to proceed ?

  • Lenny is too old. OMV needs Squeeze (6.0).

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    Lenny is too old. OMV needs Squeeze (6.0).


    Quote

    I cannot upgrade eTrayz to squeeze as the kernel source is only 2.6.24.4.


    Backport ?

  • I have a feeling you would have to backport a lot of packages. The kernel isn't really the problem.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    The kernel isn't really the problem.


    udev from squeeze needs at least kernel 2.6.31 ----> so what you mean no problem ?

  • Quote from "intrax"


    udev from squeeze needs at least kernel 2.6.31 ----> so what you mean no problem ?


    My bad... I didn't look completely into it. I was just kind of saying the kernel is the least of the problems. There is a good chance it still doesn't work even if you use the backports.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"


    My bad... I didn't look completely into it. I was just kind of saying the kernel is the least of the problems. There is a good chance it still doesn't work even if you use the backports.


    So I'm stuck ?
    OMV used to run on lenny... are there any 'old' lenny installs around ?

  • Quote from "intrax"

    So I'm stuck ?
    OMV used to run on lenny... are there any 'old' lenny installs around ?


    OMV has always run on Squeeze (at least since first public 0.2 release). I've never seen OMV installed successfully on Lenny. I would say you are stuck since the etrayz seems to be a little too closed source.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You might have better luck using a Pogoplug Pink or Raspberry Pi (both cheap). I had MyBook World Edition II that used the oxnas810 and it was slow. Both of my suggestions are much faster.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    OMV has always run on Squeeze (at least since first public 0.2 release). I've never seen OMV installed successfully on Lenny. I would say you are stuck since the etrayz seems to be a little too closed source.


    Bleh not a 'good' newzz... :cry:
    Is it possible to run squeeze with udev from lenny ?

  • I split this topic to better reflect your device :)


    Not sure about that. The configuration files may be too different which would make OMV not work.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    I split this topic to better reflect your device


    nice... :)
    I will try to update the kernel somehow...
    I stumble on... thanks your replies !

  • If you can install the build-essential package and there is a config file in /boot, it might be fairly easy to compile a new kernel. Just depends on how many patches they applied to the kernel on the device.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    If you can install the build-essential package and there is a config file in /boot, it might be fairly easy to compile a new kernel. Just depends on how many patches they applied to the kernel on the device.


    I have a kernel config and allready cross-compiled the kernel with emdebian toolchain, but eTrayz published kernel sources are only 2.6.24.4... so I don't see how to upgrade to a kernel that can support squeeze... :cry:

  • Sorry, I don't think there much else you can do.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    Sorry, I don't think there much else you can do.


    Can anyone point me towards 2.6.31 oxnas-810 kernel-sources for eTrayz ?

  • I doubt they exist since the device is out of production.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    I doubt they exist since the device is out of production.


    Maybe other device still in op using same soc ?

  • I know you asked this before and I guess it can be done. On the MyBook World Edition II (oxnas810 also), they use Lenny's kernel and udev running on squeeze. Check here.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    I know you asked this before and I guess it can be done. On the MyBook World Edition II (oxnas810 also), they use Lenny's kernel and udev running on squeeze. Check here.


    Yep it's what I'm using now but than I refer you to the first post of this thread... no OMV... so no solution...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!