RDP to Virtualbox

  • I didn't know you could do that,


    nice

    omv 3.0.56 erasmus | 64 bit | 4.7 backport kernel
    SM-SC846(24 bay)| H8DME-2 |2x AMD Opteron Hex Core 2431 @ 2.4Ghz |49GB RAM
    PSU: Silencer 760 Watt ATX Power Supply
    IPMI |3xSAT2-MV8 PCI-X |4 NIC : 2x Realteck + 1 Intel Pro Dual port PCI-e card
    OS on 2×120 SSD in RAID-1 |
    DATA: 3x3T| 4x2T | 2x1T

  • So, we run these commands on OMV ?

  • I can't use Virtualbox either. It only tells me "vnc://ip:port". But if I click on it, nothing happens ("site cannot be found"). If I enter this into a vnc-client --> nothing. How can I use RDP over the virtualbox host again? It worked so great with "rdp://ip:port" instead of "vnc://ip:port". I did the --vrde on thing but it didn't help, still get this silly vnc-stuff

  • Hey guys, I've had the same problem today: I'd wanted to install a fresh debian VM but was unable to login to the vrdp-session for using the graphical debian installer.
    I wasn't able to connect via rdp nor via vnc (using Ubuntu with Vinagre Client). After trying different network settings (NAT, bridged...), googling around, reading docs on the omv forum and the virtualbox manual, I found an easy solution for my "issue": When connecting to the machine via rdp, you have to specify a user in the connection window, even if you've choose Authentication Method "None" in the phpVirtualBox settings! Works like a charm! :whistling:


    Maybe I'm just the most stupid user in the world, but maybe this may help anyone with the same foolishness ;)

  • VNC doesn't work anymore on my Virtualbox either.
    I have 5.2.2.22 Debian in hosting.


    The VNC viewer just give a black screen. i Know my VM is started and works cause i can use my jeedom server on it. I can see move the mouse in the preview screen in the phpVirtualbox ...



    should I go to RDP ?


    Thanks

  • i did su - vbox -c 'VBoxManage modifyvm "VM name" --vrde on', i don't have access on rdp neither :(
    i use the host's ip (tryed the VM too) with and without port 9000


    and now, in the preview window, i don't have the logon page of my unbuntu but just [ OK] Removed slice User Slicen of debian-gdm ... weird

  • As far as I understand the vrdp option in VirtualBox, you have to see this as a kind of console access to the virtual machine, similar to a physical screen connected to a physical video port (e.g. VGA) on a dedicated machine.
    There is no need for the guest os to support rdp or even less complex: There is no need for a guest os at all!
    VBox will provide video output from the virtual machine via rdp on the port that you choose (default is the port range 9000 to 9100, resulting in port 9000 as long as it is the first vm on your host).
    If you're fast enough, you will probably see the virtual bios (I never tried that out...).

  • Hi,


    I've got the same problem with the last update (5.2.22).
    It is a virtualbox problem an comes with the version 5.2.20 (see here).
    A patch was paste to the svn of virtualbox (see here...) an now we have to wait to the
    new version from debian-backports.


    I think there is nothing we can do to fix it with 'some' settings.


    Regards :)


    P.S.:
    I've posted the problem to the debian-backports mailing-list. Now we must wait for the update... ;)

  • got a problem with VM Console, since i got RDP enable only on local host 127.0.0.1, how to i change it?


    see screenshot

    Just delete 127.0.0.1 and leave that field blank.
    It should re-write proper address itself.


    I've got another question. VM is running, I can connect via RDP with no problem, but when I start VM and some time passes (several minutes or so), when I'm getting back to phpVirtualBox tab, there's an error message like below. How can I get rid of it?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!