MySQL Plugin 1.0.16 stopped working

  • Hi guys,

    I was not using my machine for a while. After turning it on again and updating everything I saw, that the status of MySQL was "red" even if the service was still started. Logging in to Management Site was not possible, too. So I reinstalled it, but this didn't solve the issue. Then I completely reinstalled my OMV and MySQL was working for a few hours. I run a new search with Kody and afterwards MySQL stopped again.

    Today I tried purging the package (like I read in several topics here), reinstalling it several times and in the end deleted the MySQL user.
    Now if I reinstall the package the MySQL user is still missing. But all in all I don't think that reinstalling the package now would solve the issue.

    Could you please advice how to get MySQL installed again (with the user) and up and running? Which logs do you need from me?

    Thanks in advance.

    Edit: Error message by starting the plugin

    Failed to execute command 'export LANG=C; invoke-rc.d 'mysql' stop 2>&1': Stopping MySQL database server: mysqldWarning: World-writable config file '/etc/mysql/conf.d/pw.cnf' is ignored failed! invoke-rc.d: initscript mysql, action "stop" failed.

    Edit2 (27.12.16): I did now again a complete fresh install of OMV, but im still not able to start MySQL. Could there be something wrong with privileges/ACL?

    So I deleted my old database folder and its content and tried starting from scratch but even with empty folders mysql won't start up.

  • I finally found a solution for my problem:

    I remembered, that my approach was to remove all rights for non-users (“all others”) from all shares. But since I defined the root folders of each partition as share I removed the rights for all non-users from root.

    Then I found a topic where it was mentioned, that mysql is no standard user, so belongs to the non-users and needs rights to browes to his data folder. -> my problem maybe just was a simple rights problem, even if it does not explain why this problem just came after some time but in the end was persistent.

    I had another issue to correct this because the web GUI was not able to reset the privileges and ACL.

    I read about the difference of privileges and ACL here and decided to do it all new and grant all non-users read rights to avoid future issues, even if I don’t want them to have this rights.

    1.) So I deleted everything like described here,

    apt-get purge mysql-server-5.5 mysql-server-core-5.5 mysql-common
    apt-get autoremove
    rm -rfv /etc/mysql
    rm -rfv /var/lib/mysql
    userdel mysql

    2.) corrected the rights via CLI (more informations in german and english),

    chmod -R 775 <path>

    3.) checked them,

    ls -l <path>

    4.) installed the MySQL package directly, since the the plugin did not work anymore for me.

    apt-get install mysql-server

    5.) then installed the plugin to correct the needed web GUI things,
    6.) created a new folder via CLI for the plugin,
    mkdir <path>

    7.) configured the MySQL Plugin,

    8.) and started the MySQL Server -> worked now.

    All rights are inherited at the moment and set on root to 775. The only change was made by the MySQL Plugin itself.

    Now the last thing I have to do is to restore my old database.

    Maybe this helps someone else, too.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!