Problem installing backport kernel OMV3.0 (extras)

  • Hello,


    I want to install the backport kernel in OMV 3.0. (A OMV 2.0 that had the backport kernel) upgraded to 3.0
    When I install the backport kernel I have a message telling me that is is already installed.


    Install backports 4.8.0-0.bpo.2 kernel and headers
    Reading package lists...
    Building dependency tree...
    Reading state information...
    firmware-linux-free is already the newest version.
    linux-headers-4.8.0-0.bpo.2-amd64 is already the newest version.
    linux-image-4.8.0-0.bpo.2-amd64 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 70 not upgraded.
    ...
    Please reboot to use new kernel




    uname -a gives


    Linux openmediavault 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux.




    A reboot didn't help.


    Thank you
    Marc

  • OMV 3.x enables and install the backports kernel as an update now. So, you have it installed but grub isn't setup to boot from it. Change default boot kernel in the Kernel tab of omv-extras.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    The only choices I have are
    Debian GNU / Linux
    Clonezilla live
    Parted Magic.


    There is no boot option for the 4.8


    How can I add the option?
    Thank you
    Marc

  • Clicking the install backports command should've have done it. Have you rebooted since you clicked on that? If so, what is the output of:


    grep GRUB_DISABLE_SUBMENU /etc/default/grub

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Try update-grub and then reboot. If that still doesn't work, what is the output of: dpkg -l | grep grub

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    update-grub doesn't work


    # update-grub
    -bash: update-grub : commande introuvable
    (Can't find command)



    dpkg -l | grep grub
    rc grub-common 2.02-beta2.9-ZOL11-7aa9f6-wheezy amd64 GRand Unified Bootloader (common files)
    rc grub-pc 2.02-beta2.9-ZOL11-7aa9f6-wheezy amd64 GRand Unified Bootloader, version 2 (PC/BIOS version)



    EDIT :
    I have made
    sudo apt-get update; sudo apt-get install --reinstall grub


    After that I was able to do
    /usr/sbin/update-grubuname -a still gives a 3.16 kernelIn the kernel selection of OMV, I see no 4.x kernelI can also see no 4.8 kernel in the boot menu (advanced)Thanks again
    Marc

  • It is because you have the zfs version of grub installed. What is the output of: apt-cache policy grub-pc grub-common

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    It is


    Installée : (aucun)
    Candidat : 2.02~beta2-22+deb8u1
    Table de version :
    2.02-beta2.9-ZOL11-7aa9f6-wheezy 0
    100 /var/lib/dpkg/status
    2.02~beta2-22+deb8u1 0
    500 http://ftp.belnet.be/debian/ jessie/main amd64 Packages
    500 http://security.debian.org/ jessie/updates/main amd64 Packages
    500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
    grub-common:
    Installé : 2.02~beta2-22+deb8u1
    Candidat : 2.02~beta2-22+deb8u1
    Table de version :
    *** 2.02~beta2-22+deb8u1 0
    500 http://ftp.belnet.be/debian/ jessie/main amd64 Packages
    500 http://security.debian.org/ jessie/updates/main amd64 Packages
    500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
    100 /var/lib/dpkg/status

  • apt-get install grub-pc=2.02~beta2-22+deb8u1

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    It is working perfectly now.
    After the first boot with the kernel,, I had to import my zfs pool again but after the next reboot all was fine.


    Thank you very much
    Marc

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!