iSCSI Plugin - incompatible with 4.8 kernel

  • Has anyone been able to enable the iSCSI plugin under OMV 3.0?


    I am able to install it, but when I go to enable, it returns an error.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start iscsitarget 2>&1' with exit code '1': Job for iscsitarget.service failed. See 'systemctl status iscsitarget.service' and 'journalctl -xn' for details.


    From the command line it appears that the kernel module is not compiling.


    systemctl status iscsitarget.service
    ● iscsitarget.service - LSB: Starts and stops the iSCSI software target
    Loaded: loaded (/etc/init.d/iscsitarget)
    Active: failed (Result: exit-code) since Thu 2017-01-26 17:28:09 MST; 2s ago
    Process: 32332 ExecStart=/etc/init.d/iscsitarget start (code=exited, status=1/FAILURE)
    Jan 26 17:28:09 Icarus iscsitarget[32332]: Starting iSCSI enterprise target service:modprobe: FATAL: Module iscsi_trgt not found.
    Jan 26 17:28:09 Icarus iscsitarget[32332]: failed!
    Jan 26 17:28:09 Icarus systemd[1]: iscsitarget.service: control process exited, code=exited status=1
    Jan 26 17:28:09 Icarus systemd[1]: Failed to start LSB: Starts and stops the iSCSI software target.
    Jan 26 17:28:09 Icarus systemd[1]: Unit iscsitarget.service entered failed state.


    Multiple attempts to manually override, compile, re-install are met with the same outcome.
    Tried bare metal and virtual and got the same result.

  • It doesn't compile with the 4.8 kernel. I haven't tried recently but I would try install the proxmox 4.4 kernel (button in omv-extras) and see if it compiles with that kernel. Otherwise, you will need to install OMV 3.x with one of the older ISOs and disable the backports repo.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!