How to expand 4x2TB Raid 5 Array to 4x4TB ?

  • Hello,


    recently, i made a NAS with OMV 2.2, 4x2TB and a SSD on my HP microserv gen8. It works fine.


    After loading it and getting an almost full storage, i decided to replace each 2TB hdd by 4TB hdd, one by one, step by step.



    1st, i shutdown, then get out the 1st 2TB HDD, then replace by a 4TB HDD, then start, then add physical disk, regenerate and after 4 steps, i get a new 5,5TB volume with 4x4TB array.


    i would like to grow the volume to maximum capacity. I can not to this capacity extension


    what i did:


    i go to Raid managment module, select the relevant volume, and then i click on Grow button. but nothing appears.


    What do i have to do to get a new volume, extended to a 4x4TB array :?:


    thanks.


    Genna

  • hello @Fambank, no i didn't read it, but i 'll read it. (Edit: DONE !! )


    thanks for the link, very helpfull. Exactly what i was looking for :)


    i have some difficulties to foundout what i am looking for in this forum, i can't really see if i am in the right section.
    On my OMV 2.x webgui, in help section, the links go to the Wiki OMV 3 or documentation, but all is empty.


    so thanks, i will read this.


    as i am used with NAS from Synology, MyCloud, Netgear and their webguis have an automatic feature to grow up the partition or volume, i was sure that i found it in OMV but not really.


    Edit:


    i run ssh session, connected as root


    then,



    Code
    mdadm --detail /dev/md*


    i get this answer:

    then i run this command:

    Code
    mdadm --grow /dev/md0 --size=max

    and i get this answer:


    Code
    mdadm: component size of /dev/md0 has been set to 3906887168K

    and on my OMV webgui, i can see immediately that re-sync starts.



    THANK YOU For your Quick and Helpful answer :)


    Genna

  • Hello,


    do i need to do something else ? Yes. I have to use the Resize Button present in System Files Module.


    So, just before, the Raid 5 array with 4x4TB hdd has its maximum size. Process on md0 is done.


    In Raid Management module, the volume size is bigger than previous size. The wanted size, is now 10,92TiB.



    Now, in the File System module, i choose the Resize button, and i head hdds working but any message or new popup window to say 'job is started'... So i thought i did not click and i clicked again. Then a error message that says the process can not be run. In fact, the resize process already run :)


    I heard the HDDs working. And in File systems module, i can see the size growing up, after a moment. a "Work in progress message" would be fine in this case.


    I will have some new questions in a close future... but for the moment, it is good. Thanks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!