Installing and configuring Calibre-Server

  • Check content of the following file:

    Code
    /etc/systemd/system/calibre.service


    My File:



    Regarding the PID-File there is nothing inside /var/run/calibre


    The rights should also be fine

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

    Edited once, last by Zeb Aztian ().

  • how did you create the

    Code
    /etc/systemd/system/calibre.service


    file? SSH and an editor like nano?


    check if there is a

    Code
    /home/calibre/.config

    folder

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

  • I have created it as you have written in your HowTo and directly in "Nano"


    with the command



    Code
    nano etc/systemd/system/calibre.service

    Then copied your text inside and replaced XXX against my path of created "calibre folder" using share on OMV WebGUI

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

  • Is your OMV up to date or do you run the version from your signature?


    Could you free some space on this data drive?


    I'll set up a virtual machine and follow my own discription again, maybe I will discover the cause of this error, installation of OMV is running right now.

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

  • On my main drive (250GB) I have enough free Space and upgraded this morning to 3.0.94


    I give both drives which have not so much space left little bit more free space and try it again


    EDIT
    => Have now enough free space


    Code
    systemctl start calibre.service:
    Jan 10 20:29:18 HomeServer systemd[1]: Starting Calibre Service...
    Jan 10 20:29:18 HomeServer mkdir[31703]: /bin/mkdir: das Verzeichnis „/var/run/calibre“ kann nicht angelegt werden: Die Datei existiert bereits
    Jan 10 20:29:29 HomeServer systemd[1]: PID file /var/run/calibre/calibre-server.pid not readable (yet?) after start.
    Jan 10 20:29:29 HomeServer systemd[1]: calibre.service never wrote its PID file. Failing.
    Jan 10 20:29:29 HomeServer systemd[1]: Failed to start Calibre Service.
    Jan 10 20:29:29 HomeServer systemd[1]: Unit calibre.service entered failed state.

    to 4. do you think it makes sense to delete the "calibre" folder and let create it through the start?
    EDIT END


    Thanks for taking time and rebuilding this on your VM :)

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

    Edited once, last by Zeb Aztian ().

  • In

    Code
    etc/systemd/system/calibre.service

    use

    Code
    ExecStartPre=-/bin/mkdir -p /var/run/calibre/
    ExecStartPre=/bin/chown -R calibre:users /var/run/calibre/

    Which overrides the folder anyways and sets permissions. I edited my howto post as well. But this should not cause this error, this should only be a problem at reboot or restarting the service.


    Edit: VM install in VirtualBox is sooo damn slow X/

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

    Edited once, last by riff-raff ().

  • Oh man I am so sorry for that :|X/
    We can stop if you want I don't want to steal your evening ... Its sad that it doesn't work but that's ok


    please see below the new

    Code
    etc/systemd/system/calibre.service


    and here when I

    Code
    systemctl start calibre.service


    and the request


    Code
    systemctl status calibre.service



    I don't know....

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

  • did you try

    Code
    systemctl daemon-reload

    as recommended?

    tried it now and still failing with same error as above....
    do you think that's a problem because I have "DOCKER" Plugin installed with calibre? (As of Post ebook server )

    I tried that this morning...

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

  • In my fresh OMV 3.0.94 install, I followed the provided howto and I get an runnig calibre-server.


    I used a single virtual data drive.


    My

    Code
    /etc/systemd/system/calibre.service




    looks like this:


    Code
    systemctl start calibre.service

    runs through without any issue

    Code
    systemctl status calibre.service

    gives me


    checking in browser my ip:9400 gives me an empty, but still running calibre




    You should check your configs and permissions. I do not think docker could cause this problem. Like your Log says, PID is not or could not be created, so check there PID is defined and check permissions where it should be placed.

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

    Edited 3 times, last by riff-raff ().

  • Good Morning,


    thanks for your result. I guess the problem is that the folder var/run/calibre have no rights to get be written? How can I set up those rights? via Symlink? If yes how do I do that?


    EDIT: I tried to activate the Homefolder on SMB to access rights on it but got an error:

    Code
    Fehler #0:
    exception 'OMV\ConstraintException' with message 'Can't share user home directories because they are not enabled.' in /usr/share/openmediavault/engined/rpc/smb.inc:85
    Stack trace:
    #0 [internal function]: OMVRpcServiceSmb->setSettings(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
    #3 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('SMB', 'setSettings', Array, Array, 1)
    #4 {main}


    Regarding the SSH Tool I am using is "Termius" on Mac. It´s like the normal terminal and the box with blue background is midnight commander installed on OMV for file browsing

  • The write permission is set by the startup script, since its owned by 'calibre', service is started with user 'calibre'


    You could try to modify the ownership by hand

    Code
    chown -R calibre:users /var/run/calibre
    chmod 755 /var/run/calibre

    should look like this

    Code
    drwxr-xr-x 2 calibre users 60 Jan 11 10:10 calibre

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

  • Same Error...




    Do you know what the "result: recources" means? ...


    How can I have a look at


    Code
    drwxr-xr-x 2 calibre users 60 Jan 11 10:10 calibre

    EDIT: I have disconnected the fuller HDD´s and got now by journalctl -xn the following error: Seems to have something to do with PLEX



    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

    Edited once, last by Zeb Aztian ().

  • 'resources' is just a generic error message that says task (start, stop, reload, etc.) can't be performed. (See systemd git)


    Is there enough space on your OMV-root drive to place a data like the PID file? What about the drive containing the library folder 'calibre'?


    Edit: Plex should not be involved, journalctl is your discrete logfile, the same you can access through web gui under protololl.


    Code
    systemctl status calibre.service

    gives you the required information.

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

    Edited once, last by riff-raff ().

  • On my main drive where is OMV installed I have currently 180Gb free Space.
    I have also moved the calibre &import folder to my other HDD where I have currently 900GB free....

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

  • Did you try to dump calibre copletely including its configs and install it fresh?

    Code
    apt-get purge calibre
    apt-get remove calibre
    apt-get install calibre

    What format does your data drive have? EXT4?

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

  • I have now tried to remove and new install calibre


    received then the same error.


    I have now also set up OMV 3.0.94 inVMbox and got the same Error. i think it´s my fault or I am doing something wrong with the rights....


    All my drives are EXT4

    Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
    2GB DDr2 RAM
    OMV 3.0.94
    2x 3TB Seagate
    1x 2TB Hitachi
    1x 250GB Samsung (Main System OMV )

  • You coppied the content of

    Code
    /etc/systemd/system/calibre.service


    with your ssh tool, maybe the error is due to faulty word wraps. Try to use another ssh tool, putty or macOS terminal (Utility -> Terminal).To connect to your server use:

    Code
    ssh ip-of-your-server -l root

    autentificate and do

    Code
    nano /etc/systemd/system/calibre.service

    place the required content there. I can't really think of anything else that could have been done wrong right now.


    Do not forget to adjust library path, check permissions or set them for user calibre within OMV web gui. Typ to aply them to subdirectories as well.

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

    Edited once, last by riff-raff ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!