• Really? I thought newer generations of CPU were not supported! Thanks for the clarification then.
    What about the new 8th generation then? Will it be supported by OMV 4?

    What wouldn't be supported? The cpu generally isn't the problem. Usually it is something with the motherboard like the network adapter. Hard to say about the 8th generation stuff since bleeding edge hardware and servers generally aren't mixed.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is why I was in doubt: New coffee lake processor

    cpu support really isn't dependent on the OMV version. The kernel is what matters. You can compile your own kernel in OMV 3.x to get support. The 4.9 backports kernel in OMV 3.x supports a lot though. The 4.13 backports kernel in OMV 4.x probably supports 8th gen stuff but I don't have one to try. Why buy such a new cpu for a server?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Well as I wrote in that topic, the new i3-8100 seems a good bargain since it has 4 cores and is pretty cheap.
    But I could easily be satistfied with a 7th generation processor.

    Try it. Then we will all know :) Or you could search for people using that cpu with Debian Jessie or Stretch. That would tell you if it would work with OMV.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    Did anyone solve this issue?


    Greetings,
    Hendrik

  • I ran into the same problem with rrdcached. The unix domain socket isn't getting created in /var/run it is being created in /tmp. I was able to work around the issue by creating a symlink /var/run/rrdcached.sock ---> /tmp/rrdcached.sock


    I was unable to determine why none of the overrides are working. I didn't find anything wrong with /etc/default/rrdcached or /etc/init.d/rrdcached. The only reason I found the socket was I found on the internet that /tmp was the default place. So perhaps rrdcached is not processing its command line options properly.


    FYI:
    ii collectd 5.7.1-1.1 arm64 statistics collection and monitoring daemon
    ii rrdcached1.6.0-1+b2arm64 data caching daemon for RRDtool
    Debian GNU/Linux 9 (stretch)
    OMV 4.0.19-1
    Linux NAS1 4.11.2 #22 SMP Sat May 27 11:14:47 CST 2017 aarch64 GNU/Linux


    This was the error message I was getting in /var/log/syslog
    Feb 21 11:03:05 NAS1 collectd[2825]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)

    Edited once, last by CVBruce: readability, added error message ().

  • I'm running OMV3, and still having this issue.


    Is this solution working out for you ?




    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • Hi,
    I have broken my new installation. I was getting the erros concerning lines 109 and 117 in "/usr/lib/python3.5/weakref.py".


    I followed the instructions to edit these lines (discussed much earlier in this thread) but accidently added characters to line 118.


    I have reformatted the text so that it looks correct but get this message:


    from weakref import WeakKeyDictionary
    File "/usr/lib/python3.5/weakref.py", line 118
    self._remove = remove
    ^
    IndentationError: unindent does not match any outer indentation level



    Now the everything has broken down and I do not know how to replace the file with its original version.


    Will I need to reinstall the whole system?


    Thanks in advance

  • If you do not have a backup of the file you could try to fix indentation of the lines you edited. It's important to keep that intact.
    Have a look here
    https://docs.python.org/2.0/ref/indentation.html


    Use spaces and no tabs.


    Or install OMV into a VM and copy thats weakref.py over your damaged one.

  • Thanks for your help.
    I have checked the spaces and all looks identical.


    The caret points to the end of the line, not the start. Is that significant?


    Can I somehow just reinstall the whole python package?

  • Regular support for Debian 8 (OMV 3.x) is ending in less than a month (2018.06.17) - link. While there are still some packages supported, it is a reduced set. OMV 3.x is also EOL'd. This should be good motivation to move to OMV 4.x.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi All,


    I recently started using OMV. I was googling for a solution to that rrdcached issue and found this thread, posting my solution here in case if anyone is looking for the same.


    My Version: 4.1.17-1 (Arrakis)


    1. Create a systemd service file ==> /lib/systemd/system/rrdcached.service








    2. Create a symlink:


    Code
    ln -s /lib/systemd/system/rrdcached.service /etc/systemd/system/multi-user.target.wants/rrdcached.service


    3. Reload systemd config

    Code
    systemctl daemon-reload

    4. Stop/enable/start the service.

    Code
    service rrdcached stop
    systemctl enable rrdcached
    service rrdcached start


    5. Check out the status


    Code
    service rrdcached status

    if you see this message in status output -- "Warning: Fake start-stop-daemon called, doing nothing." Run the following followed by by a stop/start process.



    Code
    cp /sbin/start-stop-daemon.REAL /sbin/start-stop-daemon


    In case if anyone is in need of the full command line option for rrdcached

    Code
    root@filer1:~# ps -ef | grep rrd
    root 20912 1 0 14:53 ? 00:00:00 /usr/bin/rrdcached -B -F -f 3600 -w 900 -b /var/lib/rrdcached/db/ -j /var/lib/rrdcached/journal/ -p /var/run/rrdcached.pid -l unix:/var/run/rrdcached.sock
    root 21134 13198 0 15:00 pts/0 00:00:00 grep rrd


    Thanks,

    Edited once, last by cdev19: missed one step. ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!