OMV 3.0.64 on XU4 not booting up?

  • ###############################################################


    solved: working fine with the new build omv_xu3_xu4_3.0.65.img


    https://sourceforge.net/projec…u4_3.0.65.img.gz/download


    ###############################################################



    Just got my XU4 home and wanted to build a NAS server with OMV.


    I got the image file : omv_xu3_xu4_3.0.64.img.gz


    https://sourceforge.net/projec…ult/files/Odroid-XU3_XU4/


    Prep my SD card with SD Card Formatter - https://www.sdcard.org/downloads/formatter_4/index.html


    Burned the image with Win32DiskImager from http://com.odroid.com/sigong/blog/blog_list.php?bid=144


    But the device would not boot up? No monitor connected - somehow it cause the device not to boot at all?


    Got it to boot with omv_2.1.1_xu3_xu4.img.gz


    Anyone tried the omv_xu3_xu4_3.0.64.img.gz and got it working?


    But i want to run OMV 3 ...how to get there

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

    Edited once, last by Always: solved ().

  • Anyone tried the omv_xu3_xu4_3.0.64.img.gz and got it working?

    Since I created the image, it worked on two SD cards on three different XU4s. Are you sure you got a good download of the image? Here are the md5sums.


    Code
    # md5sum omv_xu3_xu4_3.0.64.img.gz
    d1b796157e59bd6b1b99e009e0f0ebc2 omv_xu3_xu4_3.0.64.img.gz
    # md5sum omv_xu3_xu4_3.0.64.img
    52aac7db74f18093b31c69ac6ebe36f8 omv_xu3_xu4_3.0.64.img

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Just redownloaded the image and checked the md5sum with Hashmyfiles.exe


    omv_xu3_xu4_3.0.64.img.gz d1b796157e59bd6b1b99e009e0f0ebc2 40fd4cc0c78e63536232912a9bd18086c888533f c173b15a 43a1ff69eda77d413a7071520b6309c3611d30905e47b7a5cc7820bd2cfcaca6 36e2c63c6d891956d6dbffdae6a17c68912a344226d2bdd6d82c21129e362296068e66526f4ffac3f626214799ad8a3ceb80dd28a9c557f3ccff0563c4693208 e52254559e8810e6c65ed0b5cef7f2f9a01fd2d4a12505d1a899a5abb160e89e2dfb2abf1eb2a6d1f37f5f82d51f3dad C:\Users\Downloads\Odroid\omv_xu3_xu4_3.0.64.img.gz 28/02/2017 18:32:10 28/02/2017 18:25:24 28/02/2017 18:32:22 314,948,485gz A


    unpack it with 7zip and chked again. matched yours value so the file should be ok.


    omv_xu3_xu4_3.0.64.img 52aac7db74f18093b31c69ac6ebe36f8 a1eea74fbb08422e0d2b0c610362075737925829 2bfd8f1c fd257d35027e99ad6e7c6eb898c55ae69d9d7c4dbd9ac0c2578a065010b26d49 2e22b93d42f3672c0ee3a1cfd5f2032ab4ef09b598c19495434c27f52388e964fbffb24cce5ef83ca07a2cd2494cb66cd47f00e690e3e7b7ddbe597c351c8ab1 a3abf460329095fbac450595236b20652fb29c22663a1df4d5914a4532461ca5ac4f54983f59f4629e9001bed8d38afe C:\Users\Downloads\Odroid\omv_xu3_xu4_3.0.64.img 25/02/2017 20:14:44 28/02/2017 18:34:03 28/02/2017 18:34:30 4,294,967,296img A


    will use this for burning the image this time.
    https://sourceforge.net/projec…diskimager/files/Archive/

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • win32diskimager (windows) and dd (linux) are what I use.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • since : Openmediavault 3.x is in its early testing phase


    Wierd that omv 2 works fine on the sdcard but not omv 3.


    Have the superfast mmc card to but need a cardreader to burn the image. Will try when i have the reader.

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

    Edited 2 times, last by Always ().

  • I googled a little and found this blog: https://obihoernchen.net/1451/…-xu4-to-openmediavault-3/


    Because im new at this i have retype all my steps.


    but is below step correct done??


    after the update i should change the boot.ini back to "ro" read-only or that doesn't matter?


    Mount boot partition mkdir /media/boot
    mount /dev/mmcblk0p1 /media/boot
    Nano /media/boot/boot.ini Change "ro" to "rw"
    setenv bootrootfs "console=tty1 console=ttySAC2,115200n8 root=UUID=a4b494db-320a-4ce2-bb3a-841db943f9c0 rootwait ro"
    setenv bootrootfs "console=tty1 console=ttySAC2,115200n8 root=UUID=a4b494db-320a-4ce2-bb3a-841db943f9c0 rootwait rw"
    Nano /etc/fstab UUID=a4b494db-320a-4ce2-bb3a-841db943f9c0 / ext4 errors=remount-ro,noatime,no
    diratime 0 1
    Record rootfs UUID
    Add following lines
    UUID=<YOUR_ROOTFS_UUID> / ext4 errors=remount-ro,noatime,no
    diratime 0 1
    Above
    # >>> [openmediavault]
    Replace <YOUR_ROOTFS_UUID> with your rootfs UUID
    Update system apt-get update && apt-get upgrade
    Reboot Reboot
    Update OMV omv-release-upgrade
    Install OMV-Extra wget http://omv-extras.org/openmedi…extrasorg_latest_all3.deb
    dpkg -i openmediavault-omvextrasorg_latest_all3.deb
    apt-get update

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • After a long time it finished. but when i try to login the web GUI i get this.


    I have run the apt-get update as last step after the OMV upgrade and a reboot


    what gone wrong?

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • This is why I don't recommend upgrading arm systems. Just give me a few days to check the image and possibly upload a new one.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • im just out of luck...wait for your fix.


    I did the "omv-engined -df" and got this



    at the button a config is missing??


    Code
    PHP Fatal error: require_once(): Failed opening required 'openmediavault/config.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediavault/engined/rpc/flashmemory.inc on line 19

    dpkg -l | grep openm


    ii openmediavault 3.0.64 all Open network attached storage solution
    ii openmediavault-flashmemory 1.9 all folder2ram plugin for OpenMediaVault
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-omvextrasorg 3.4.21 all OMV-Extras.org Package Repositories for OpenMediaVault

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

    Edited once, last by Always ().

  • You must still have an old version of the plugin installed. What is the output of: dpkg -l | grep openm

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • the command give me this


    openmediavault 3.0.64 all Open network attached storage solution
    openmediavault-flashmemory 1.9 all folder2ram plugin for OpenMediaVault
    openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    openmediavault-omvextrasorg 3.4.21 all OMV-Extras.org Package Repositories for OpenMediaVault

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • You have the OMV 2.x version of flash memory installed which will not work.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get remove openmediavault-flashmemory


    and now i can log in again... I will play around and learn how to use omv3


    Thanks for the fast support.


    Wierd that my unit cant boot with the omv3 img. Will try that again when you release a new one

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • Will try that again when you release a new one

    Hopefully I can look at it this weekend. Not sure what I am going to fix since it works on my XU4s.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • maybe it my sdcard...but it work with your omv 2 image but not the omv 3...and i prep and burn them the same way... i will try the mmc card later i get the reader.


    What SD card are you using??

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • another thing i remove the flashmemory plugin 1.9 and rebootet. and the installation let me login now...just installed omvextraorg and checked. the plugin is somehow back and my installation still works?



    ii openmediavault 3.0.64 all Open network attached storage solution
    rc openmediavault-flashmemory 1.9 all folder2ram plugin for OpenMediaVault
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-omvextrasorg 3.4.21 all OMV-Extras.org Package Repositories for OpenMediaVault

    omv 3.0.64 (Erasmus) on XU4 (ARMv7 rev 3) | 64bit | omvextrasorg 3.4.21

  • Working on the image now. Just wrote the image to a new SD card and it works fine. They are just cheap 8gb or 16gb sandisk or whatever is cheapest on amazon. If you keep flashmemory plugin uninstalled, your SD card will probably fail in a few days/weeks.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!