OMV on RPi3 unable to display file system after adding Remote Share

  • I have installed OMV on a RPi3 - all went well for some time.


    I then decided to install Plex Media Server and to mount some remote share (from another NAS running OMV in the same network).
    These share are shared via SMB/CIFS as read only and equally mounted with the "ro" switch.


    Every time I try to browse to Storage > File Systems I get the following error.


    Bash
    Could not fetch a matching mount point from the provided fsname: '/media/56ce3c2c-9f9a-47c9-94ce-802744ba02b8'.


    The details of the error are the following.



    If I look at /etc/fstab, the entry '/media/56ce3c2c-9f9a-47c9-94ce-802744ba02b8' is there.
    Equally the mountpoint exists in the '/media/' directory and is fully accessible (II can browse the content of the share).


    Has anyone got any suggestion on how to overcome this?


    Thank you.


    Best regards,
    Tommy

  • Replying to myself in case someone else faces the same issue.


    I think there are 2 factors that have a barring on this issue.



    /etc/fstab contained some '\n' as opposed to have one entry per line.


    The Remote Share plugin was not in fact able to fetch the share from /etc/fstab as the entries were separated by '/n' and there wasn't an entry per line.


    The file looked like:

    Code
    10.0.0.1:Share1 /media/75ea105e-129b-4406-b371-7ee2ac17d7e9 nfs4 rsize=8192,wsize=8192,timeo=14,intr 0 0\n10.0.0.1:Share2 /media/acce9ca3-32cc-4bfe-ba4c-992bb5fcccc0 nfs4 rsize=8192,wsize=8192,timeo=14,intr 0 0


    I had to manually alter the file so that there was an entry per line, as follows.


    Code
    10.0.0.1:Share1 /media/75ea105e-129b-4406-b371-7ee2ac17d7e9 nfs4 rsize=8192,wsize=8192,timeo=14,intr 0 0
    10.0.0.1:Share2 /media/acce9ca3-32cc-4bfe-ba4c-992bb5fcccc0 nfs4 rsize=8192,wsize=8192,timeo=14,intr 0 0


    This has addressed the issue with the Remote Share plugin which is now able to retrieve both the NFS Shares.
    Needless to say that if I make any change via the Web UI, that reintroduces the '\n' in /etc/fstab and the issue comes back.



    The shares were not getting mounted on reboot.


    I also noticed sometimes neither of the 2 shares were getting mounted, due to a latency in acquiring an IP via DHCP.


    Adding ',ro,noexec,noauto,noatime,x-systemd.automount' to the default 'rsize=8192,wsize=8192,timeo=14,intr' seems to have addressed this problem.
    Now both the shares gets resiliently mounted after each reboot.


    /etc/fstab now looks like the following.


    Code
    10.0.0.1:Share1 /media/75ea105e-129b-4406-b371-7ee2ac17d7e9 nfs4 rsize=8192,wsize=8192,timeo=14,intr,ro,noexec,noauto,noatime,x-systemd.automount 0 0
    10.0.0.1:Share2 /media/acce9ca3-32cc-4bfe-ba4c-992bb5fcccc0 nfs4 rsize=8192,wsize=8192,timeo=14,intr,ro,noexec,noauto,noatime,x-systemd.automount 0 0


    Hope this can be of help to others as well.


    Regards,
    Tommy

  • I don't know why the linefeed character (\n) is working on some systems and not others. I will have to try my RPi.


    As far as the other issue, the noauto,x-systemd.automount are the important options. I would have to do more testing to determine if these should be default options.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!